aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-06-18 12:50:15 +0200
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-16 15:10:40 +0100
commitc4fde248b14d4be9cab6d0eff85f9d7f852a4b65 (patch)
tree0462a7b4c188f390af53d2b1a6312894774d740f /bitbake
parent2fc283c52d7d6d6bf8e67a7847f064fa20d4bc51 (diff)
downloadopenembedded-core-contrib-c4fde248b14d4be9cab6d0eff85f9d7f852a4b65.tar.gz
*: use print() as a function
to make python3 happy (Bitbake rev: c82926ccdd4ec4e3ad6e78a381dacb96adf9b409) Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'bitbake')
-rwxr-xr-xbitbake/bin/bitbake6
-rw-r--r--bitbake/doc/manual/usermanual.xml4
-rw-r--r--bitbake/lib/bb/msg.py10
3 files changed, 10 insertions, 10 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index fdf1e20f84..7caa5d95e6 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -195,13 +195,13 @@ Default BBFILES are the .bb files in the current directory.""")
uimodule = __import__("bb.ui", fromlist = [ui])
ui_init = getattr(uimodule, ui).init
except AttributeError:
- print "FATAL: Invalid user interface '%s' specified. " % ui
- print "Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'."
+ print("FATAL: Invalid user interface '%s' specified. " % ui)
+ print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
else:
try:
return_value = ui_init(serverConnection.connection, serverConnection.events)
except Exception as e:
- print "FATAL: Unable to start to '%s' UI: %s" % (ui, e)
+ print("FATAL: Unable to start to '%s' UI: %s" % (ui, e))
raise
finally:
serverConnection.terminate()
diff --git a/bitbake/doc/manual/usermanual.xml b/bitbake/doc/manual/usermanual.xml
index 7b87ad837f..748ac319ef 100644
--- a/bitbake/doc/manual/usermanual.xml
+++ b/bitbake/doc/manual/usermanual.xml
@@ -218,8 +218,8 @@ python myclass_eventhandler() {
from bb.event import getName
from bb import data
- print "The name of the Event is %s" % getName(e)
- print "The file we run for is %s" % data.getVar('FILE', e.data, True)
+ print("The name of the Event is %s" % getName(e))
+ print("The file we run for is %s" % data.getVar('FILE', e.data, True))
}
</screen></para><para>
This event handler gets called every time an event is triggered. A global variable <varname>e</varname> is defined. <varname>e</varname>.data contains an instance of bb.data. With the getName(<varname>e</varname>)
diff --git a/bitbake/lib/bb/msg.py b/bitbake/lib/bb/msg.py
index cea5efb5a4..8d2bcce452 100644
--- a/bitbake/lib/bb/msg.py
+++ b/bitbake/lib/bb/msg.py
@@ -110,7 +110,7 @@ def debug(level, msgdomain, msg, fn = None):
if debug_level[msgdomain] >= level:
bb.event.fire(MsgDebug(msg), None)
if not bb.event._ui_handlers:
- print('DEBUG: ' + msg)
+ print('DEBUG: %s' % (msg))
def note(level, msgdomain, msg, fn = None):
if not msgdomain:
@@ -119,20 +119,20 @@ def note(level, msgdomain, msg, fn = None):
if level == 1 or verbose or debug_level[msgdomain] >= 1:
bb.event.fire(MsgNote(msg), None)
if not bb.event._ui_handlers:
- print('NOTE: ' + msg)
+ print('NOTE: %s' % (msg))
def warn(msgdomain, msg, fn = None):
bb.event.fire(MsgWarn(msg), None)
if not bb.event._ui_handlers:
- print('WARNING: ' + msg)
+ print('WARNING: %s' % (msg))
def error(msgdomain, msg, fn = None):
bb.event.fire(MsgError(msg), None)
- print 'ERROR: ' + msg
+ print('ERROR: %s' % (msg))
def fatal(msgdomain, msg, fn = None):
bb.event.fire(MsgFatal(msg), None)
- print('FATAL: ' + msg)
+ print('FATAL: %s' % (msg))
sys.exit(1)
def plain(msg, fn = None):