aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-09-08 18:38:43 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-08 19:22:37 +0100
commit3e7db72216472050366c3059219660dea057e80b (patch)
tree4f29cd0ea032a1620e4d439071f668bcc16dfa8c /bitbake
parent8be5593777be3a6617791fc70e9aa47d54ca1676 (diff)
downloadopenembedded-core-contrib-3e7db72216472050366c3059219660dea057e80b.tar.gz
bitbake: save the initial PATH for use when starting a subprocess
It was possible for bitbake-runtime to be run against a semi-installed python-native resulting in tracebacks with ImportError's. To prevent this we stash the initial PATH in the BBConfiguration when bitbake is started and then set this in the env when launching bitbake-runtask through subprocesses Popen() call. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'bitbake')
-rwxr-xr-xbitbake/bin/bitbake1
-rw-r--r--bitbake/lib/bb/runqueue.py1
2 files changed, 2 insertions, 0 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 4e6815e46e..b046156b49 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -157,6 +157,7 @@ Default BBFILES are the .bb files in the current directory.""")
configuration = BBConfiguration(options)
configuration.pkgs_to_build.extend(args[1:])
+ configuration.initial_path = os.environ['PATH']
#server = bb.server.xmlrpc
server = bb.server.none
diff --git a/bitbake/lib/bb/runqueue.py b/bitbake/lib/bb/runqueue.py
index 3d84bb17ee..4d1dc49d78 100644
--- a/bitbake/lib/bb/runqueue.py
+++ b/bitbake/lib/bb/runqueue.py
@@ -1042,6 +1042,7 @@ class RunQueueExecute:
env[comps[0]] = comps[1]
env['BB_TASKHASH'] = self.rqdata.runq_hash[task]
+ env['PATH'] = self.cooker.configuration.initial_path
sys.stdout.flush()
sys.stderr.flush()