aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake/lib/bblayers
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-05-31 11:16:58 +1200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 22:13:38 +0100
commit0726b2d5cd06c2d6eecf7dbc979f2d29dda166ac (patch)
tree5742949be3db9ec1fa936106774e19bf1e395c5b /bitbake/lib/bblayers
parentdcbfc72303d6782d9108538c830cf2ee7849bf59 (diff)
downloadopenembedded-core-contrib-0726b2d5cd06c2d6eecf7dbc979f2d29dda166ac.tar.gz
bitbake: bitbake-layers: show-layers: disable parsing
We don't need to parse all recipes just to show the list of layers, since that comes straight from the configuration, so save a bit of time by not doing so. (A minor regression that came in with the the bitbake-layers refactoring). (Bitbake rev: a609ad7d560260a8d50dfa197cd960f496c5da73) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bitbake/lib/bblayers')
-rw-r--r--bitbake/lib/bblayers/query.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/bitbake/lib/bblayers/query.py b/bitbake/lib/bblayers/query.py
index b8c817b124..0a496810f2 100644
--- a/bitbake/lib/bblayers/query.py
+++ b/bitbake/lib/bblayers/query.py
@@ -481,7 +481,7 @@ NOTE: .bbappend files can impact the dependencies.
logger.plain("%s %s %s" % (f, keyword, best_realfn))
def register_commands(self, sp):
- self.add_command(sp, 'show-layers', self.do_show_layers)
+ self.add_command(sp, 'show-layers', self.do_show_layers, parserecipes=False)
parser_show_overlayed = self.add_command(sp, 'show-overlayed', self.do_show_overlayed)
parser_show_overlayed.add_argument('-f', '--filenames', help='instead of the default formatting, list filenames of higher priority recipes with the ones they overlay indented underneath', action='store_true')