aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake/lib/bb/runqueue.py
diff options
context:
space:
mode:
authorRobert P. J. Day <rpjday@crashcourse.ca>2014-08-12 04:53:16 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-19 20:41:26 +0100
commit34436672f3ef4915e7526770a0fa8dcff328f93d (patch)
treef99fae4a88ace62e2affc7bacc7caf320f49056d /bitbake/lib/bb/runqueue.py
parent02455ebfbb1e738e6b1fe57cb6a9b9012829ee31 (diff)
downloadopenembedded-core-contrib-34436672f3ef4915e7526770a0fa8dcff328f93d.tar.gz
bitbake: runqueue.py: Fix typoes/grammar in comments.
(Bitbake rev: 000fa81013205dd9bc907ff7a61f06f57637212d) Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bitbake/lib/bb/runqueue.py')
-rw-r--r--bitbake/lib/bb/runqueue.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/bitbake/lib/bb/runqueue.py b/bitbake/lib/bb/runqueue.py
index 46dca58015..e13dc57ae8 100644
--- a/bitbake/lib/bb/runqueue.py
+++ b/bitbake/lib/bb/runqueue.py
@@ -97,7 +97,7 @@ class RunQueueScheduler(object):
def __init__(self, runqueue, rqdata):
"""
The default scheduler just returns the first buildable task (the
- priority map is sorted by task numer)
+ priority map is sorted by task number)
"""
self.rq = runqueue
self.rqdata = rqdata
@@ -186,7 +186,7 @@ class RunQueueSchedulerCompletion(RunQueueSchedulerSpeed):
"""
A scheduler optimised to complete .bb files are quickly as possible. The
priority map is sorted by task weight, but then reordered so once a given
- .bb file starts to build, its completed as quickly as possible. This works
+ .bb file starts to build, it's completed as quickly as possible. This works
well where disk space is at a premium and classes like OE's rm_work are in
force.
"""
@@ -795,7 +795,7 @@ class RunQueueData:
for st in self.cooker.configuration.invalidate_stamp.split(','):
invalidate_task(fn, "do_%s" % st, True)
- # Interate over the task list and call into the siggen code
+ # Iterate over the task list and call into the siggen code
dealtwith = set()
todeal = set(range(len(self.runq_fnid)))
while len(todeal) > 0:
@@ -967,11 +967,11 @@ class RunQueue:
stampfile = bb.build.stampfile(taskname, self.rqdata.dataCache, fn)
- # If the stamp is missing its not current
+ # If the stamp is missing, it's not current
if not os.access(stampfile, os.F_OK):
logger.debug(2, "Stampfile %s not available", stampfile)
return False
- # If its a 'nostamp' task, it's not current
+ # If it's a 'nostamp' task, it's not current
taskdep = self.rqdata.dataCache.task_deps[fn]
if 'nostamp' in taskdep and taskname in taskdep['nostamp']:
logger.debug(2, "%s.%s is nostamp\n", fn, taskname)
@@ -1688,7 +1688,7 @@ class RunQueueExecuteScenequeue(RunQueueExecute):
process_endpoints(endpoints)
- # Build a list of setscene tasks which as "unskippable"
+ # Build a list of setscene tasks which are "unskippable"
# These are direct endpoints referenced by the build
endpoints2 = {}
sq_revdeps2 = []