aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake/lib/bb/cooker.py
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-14 11:44:34 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-14 11:44:34 +0000
commit853280f161ed24f9b976a6f53739c08ac2362ddb (patch)
treeae67e05e66c92dd3fc668b1976084a628bc99882 /bitbake/lib/bb/cooker.py
parent097076da2349e638342e69e465c85683adb6ccc7 (diff)
downloadopenembedded-core-contrib-853280f161ed24f9b976a6f53739c08ac2362ddb.tar.gz
bitbake: Update with changes from bitbake 1.8 branch
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4006 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'bitbake/lib/bb/cooker.py')
-rw-r--r--bitbake/lib/bb/cooker.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/bitbake/lib/bb/cooker.py b/bitbake/lib/bb/cooker.py
index 38a8209760..619791f174 100644
--- a/bitbake/lib/bb/cooker.py
+++ b/bitbake/lib/bb/cooker.py
@@ -473,11 +473,11 @@ class BBCooker:
# Load data into the cache for fn
self.bb_cache = bb.cache.init(self)
- self.bb_cache.loadData(fn, self.configuration.data)
+ self.bb_cache.loadData(fn, self.configuration.data)
# Parse the loaded cache data
self.status = bb.cache.CacheData()
- self.bb_cache.handle_data(fn, self.status)
+ self.bb_cache.handle_data(fn, self.status)
# Tweak some variables
item = self.bb_cache.getVar('PN', fn, True)
@@ -493,7 +493,7 @@ class BBCooker:
# Remove stamp for target if force mode active
if self.configuration.force:
bb.msg.note(2, bb.msg.domain.RunQueue, "Remove stamp %s, %s" % (self.configuration.cmd, fn))
- bb.build.del_stamp('do_%s' % self.configuration.cmd, bbfile_data)
+ bb.build.del_stamp('do_%s' % self.configuration.cmd, self.configuration.data)
# Setup taskdata structure
taskdata = bb.taskdata.TaskData(self.configuration.abort)
@@ -573,6 +573,7 @@ class BBCooker:
bb.msg.debug(1, bb.msg.domain.Collection, "collecting .bb files")
(filelist, masked) = self.collect_bbfiles()
+ bb.data.renameVar("__depends", "__base_depends", self.configuration.data)
self.parse_bbfiles(filelist, masked, self.myProgressCallback)
bb.msg.debug(1, bb.msg.domain.Collection, "parsing complete")