aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake/lib/bb/cooker.py
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-29 16:09:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-30 12:01:29 +0100
commit1ca71e5178ed8514655524f714877e02f6db90af (patch)
tree38fb01d8f32ccb8256155ee9b972196bd2d8050c /bitbake/lib/bb/cooker.py
parent292c3e82e3452710a238db6312c9c71ba5416915 (diff)
downloadopenembedded-core-contrib-1ca71e5178ed8514655524f714877e02f6db90af.tar.gz
bitbake: cooker: Ensure bbappend order is deterministic
Currently bbappend files in a layer are applied in the order they're found on disk (as reported by glob) which means things are not deterministic. By sorting the glob results, the order becomes deterministic, the parsing order for .bb files also should be deterministic as a result of this change. [YOCTO #9138] (Bitbake rev: 3f8febc4212fbd3485ac9bdd4ac71b8fb0a05693) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bitbake/lib/bb/cooker.py')
-rw-r--r--bitbake/lib/bb/cooker.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/bitbake/lib/bb/cooker.py b/bitbake/lib/bb/cooker.py
index 96cefc73fd..771932a82d 100644
--- a/bitbake/lib/bb/cooker.py
+++ b/bitbake/lib/bb/cooker.py
@@ -1768,7 +1768,8 @@ class CookerCollectFiles(object):
globbed = glob.glob(f)
if not globbed and os.path.exists(f):
globbed = [f]
- for g in globbed:
+ # glob gives files in order on disk. Sort to be deterministic.
+ for g in sorted(globbed):
if g not in newfiles:
newfiles.append(g)