summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-08-17 11:27:30 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-18 17:00:16 +0100
commit5dad15af8b3423ad9631edf3eef6e77902f1b36e (patch)
tree9981bb4b0925a3b5d6f70a11392418b5b35112f0
parent8059018ae2f8cb731b58a3bc7b0c7392657adcfb (diff)
downloadopenembedded-core-contrib-5dad15af8b3423ad9631edf3eef6e77902f1b36e.tar.gz
lttng-modules: update to 2.13.0
Updating to 2.13.0, so we can pick up the latest -stable and support for 5.14+ kernels. We refresh one patch for new context, and update the LICENSE checksum due to commit 2df37e95fa4303 [Cleanup: Move headers from toplevel to include/lttng/]. which impacted the LICENSE file (but licensing is the same). MODULES_MODULE_SYMVERS_LOCATION must also be specified in this release, as the lttng build has moved the module target to a 'src' subdirectory. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules/Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch32
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.13.0.bb (renamed from meta/recipes-kernel/lttng/lttng-modules_2.12.6.bb)6
2 files changed, 14 insertions, 24 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules/Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch b/meta/recipes-kernel/lttng/lttng-modules/Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch
index e411242272..a852834344 100644
--- a/meta/recipes-kernel/lttng/lttng-modules/Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch
+++ b/meta/recipes-kernel/lttng/lttng-modules/Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch
@@ -13,37 +13,25 @@ available, allowing it to be kept being pulled by default.
Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+[bva: modified for lttng-modules 2.13+ context]
+Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
Makefile | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
-diff --git a/Makefile b/Makefile
-index 8602649..75550cc 100644
---- a/Makefile
-+++ b/Makefile
-@@ -8,10 +8,7 @@ ifneq ($(KERNELRELEASE),)
- # and defines the modules to be built.
+Index: lttng-modules-2.13.0/Makefile
+===================================================================
+--- lttng-modules-2.13.0.orig/Makefile
++++ lttng-modules-2.13.0/Makefile
+@@ -7,6 +7,11 @@
- ifdef CONFIG_LOCALVERSION # Check if dot-config is included.
-- ifeq ($(CONFIG_TRACEPOINTS),)
-- $(error The option CONFIG_TRACEPOINTS needs to be enabled in your kernel configuration)
-- endif # CONFIG_TRACEPOINTS
-- endif # ifdef CONFIG_LOCALVERSION
-+ ifneq ($(CONFIG_TRACEPOINTS),)
-
- TOP_LTTNG_MODULES_DIR := $(shell dirname $(lastword $(MAKEFILE_LIST)))
-
-@@ -94,6 +91,10 @@ ifneq ($(KERNELRELEASE),)
- obj-$(CONFIG_LTTNG) += lib/
- obj-$(CONFIG_LTTNG) += tests/
+ obj-$(CONFIG_LTTNG) += src/
-+ else
++ ifdef CONFIG_LOCALVERSION # Check if dot-config is included.
++ ifneq ($(CONFIG_TRACEPOINTS),)
+ $(warning The option CONFIG_TRACEPOINTS needs to be enabled in your kernel configuration)
+ endif # CONFIG_TRACEPOINTS
+ endif # ifdef CONFIG_LOCALVERSION
else # KERNELRELEASE
# This part of the Makefile is used when the 'make' command is runned in the
---
-2.1.4
-
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.12.6.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.0.bb
index c46faaee58..b95d7ecaaf 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.12.6.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.0.bb
@@ -3,7 +3,7 @@ SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
HOMEPAGE = "https://lttng.org/"
LICENSE = "LGPLv2.1 & GPLv2 & MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
inherit module
@@ -13,12 +13,14 @@ SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
"
-SRC_URI[sha256sum] = "95ac2a2cf92d85d23ffbdaca6a1ec0d7c167211d1e0fb850ab90004a3f475eaa"
+SRC_URI[sha256sum] = "5ebf2b3cd128b3a1c8afaea1e98d5a6f7f0676fd524fcf72361c34d9dc603356"
export INSTALL_MOD_DIR="kernel/lttng-modules"
EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
+MODULES_MODULE_SYMVERS_LOCATION = "src"
+
do_install:append() {
# Delete empty directories to avoid QA failures if no modules were built
find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;