aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-07-26 13:00:27 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-27 15:39:17 +0100
commitf7b1ccfaa15e2dd4ff25f2a5f56ac3aff63c7288 (patch)
treefe3f1b33e9fba6510129bd31c82c18e4a9a6f793
parentf520b91f878bb16b4b351ddb5f2240e318181044 (diff)
downloadopenembedded-core-contrib-f7b1ccfaa15e2dd4ff25f2a5f56ac3aff63c7288.tar.gz
linux-libc-headers: Fix file conflict -- ..install.cmd
The ..install.cmd conflicts between various configure runs. This isn't used anywhere, so remove it to avoid the conflict. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb5
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.37.2.bb5
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb5
3 files changed, 13 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
index a9b041fb08..1c709cbc23 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -10,7 +10,7 @@ RPROVIDES_${PN}-dev = "linux-libc-headers-dev"
RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg"
SRCREV = "69cfbdf9f1ff461a75e5b77d6d7ba35e97db4cc3"
PV = "2.6.37+git-${SRCPV}"
-PR = "r3"
+PR = "r4"
SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
@@ -47,6 +47,9 @@ do_compile () {
do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+
+ # The ..install.cmd conflicts between various configure runs
+ find ${D}${includedir} -name ..install.cmd | xargs rm -f
}
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.37.2.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.37.2.bb
index 51c4926429..55d752798a 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.37.2.bb
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.37.2.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r1"
+PR = "r2"
SRC_URI += " file://connector-msg-size-fix.patch"
@@ -43,6 +43,9 @@ do_install() {
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
# Kernel should not be exporting this header
rm -f ${D}${exec_prefix}/include/scsi/scsi.h
+
+ # The ..install.cmd conflicts between various configure runs
+ find ${D}${includedir} -name ..install.cmd | xargs rm -f
}
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb
index 65c19ecea6..14f5e8a1ae 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb
@@ -9,6 +9,8 @@ SRC_URI[sha256sum] = "584d17f2a3ee18a9501d7ff36907639e538cfdba4529978b8550c461d4
S = "${WORKDIR}/linux-${PV}"
+PR = "r2"
+
set_arch() {
case ${TARGET_ARCH} in
alpha*) ARCH=alpha ;;
@@ -44,6 +46,9 @@ do_install() {
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
# Kernel should not be exporting this header
rm -f ${D}${exec_prefix}/include/scsi/scsi.h
+
+ # The ..install.cmd conflicts between various configure runs
+ find ${D}${includedir} -name ..install.cmd | xargs rm -f
}
BBCLASSEXTEND = "nativesdk"