aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-07-22 16:39:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-25 12:38:42 +0100
commitb3e68f112cff5f15b5245582eee7e087acbad2fa (patch)
tree00ab337aa8f06e55fa009136c8112a04ba59a355
parentb4eef2e1bed0536325342ca884ee0905b7e79ada (diff)
downloadopenembedded-core-contrib-b3e68f112cff5f15b5245582eee7e087acbad2fa.tar.gz
docbook-dsssl-stylesheets-native: Add SYSROOT_PREPROCESS_FUNC
[YOCTO #1250] This added function will install a private install-catalog binary so that shared state can find the binary as there is not a guarantee. Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb b/meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb
index 88d24dd949..a776ea50ed 100644
--- a/meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb
+++ b/meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://README;beginline=41;endline=74;md5=875385159b2ee76ecf
DEPENDS = "sgml-common-native"
-PR = "r2"
+PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/docbook/docbook-dsssl-${PV}.tar.bz2"
@@ -19,6 +19,8 @@ S = "${WORKDIR}/docbook-dsssl-${PV}"
inherit native
SSTATEPOSTINSTFUNCS += "docbook_dsssl_stylesheets_sstate_postinst"
+SYSROOT_PREPROCESS_FUNCS += "docbook_dsssl_sysroot_preprocess"
+
do_install () {
# Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/docbook-dsssl.html
@@ -42,8 +44,14 @@ docbook_dsssl_stylesheets_sstate_postinst () {
then
# Ensure that the catalog file sgml-docbook.cat is properly
# updated when the package is installed from sstate cache.
- install-catalog \
+ ${SYSROOT_DESTDIR}${bindir_crossscripts}/install-catalog-docbook-dsssl \
--add ${sysconfdir}/sgml/sgml-docbook.cat \
${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat
fi
}
+
+docbook_dsssl_sysroot_preprocess () {
+ install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+ install -m 755 ${STAGING_BINDIR_NATIVE}/install-catalog ${SYSROOT_DESTDIR}${bindir_crossscripts}/install-catalog-docbook-dsssl
+}
+