aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-07-25 10:08:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-27 11:54:48 +0100
commit1c24f36e982e680871bf7a05ac6e820314e19c7c (patch)
tree398a180a4bb4a37bbb4ca6c569bf1c5003827a0d
parent7bdc14b0537afa004830f1f23253b2778bb0e098 (diff)
downloadopenembedded-core-contrib-1c24f36e982e680871bf7a05ac6e820314e19c7c.tar.gz
dropbear: don't override DISTRO_TYPE if it is already set
The long term solution is to remove the IMAGE_FEATURE check since images are not allowed to influence recipe compile options. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta/recipes-core/dropbear/dropbear.inc2
-rw-r--r--meta/recipes-core/dropbear/dropbear_0.52.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/dropbear/dropbear.inc b/meta/recipes-core/dropbear/dropbear.inc
index 1b51e1a588..526a5a045d 100644
--- a/meta/recipes-core/dropbear/dropbear.inc
+++ b/meta/recipes-core/dropbear/dropbear.inc
@@ -29,7 +29,7 @@ SBINCOMMANDS = "dropbear dropbearkey dropbearconvert"
BINCOMMANDS = "dbclient ssh scp"
EXTRA_OEMAKE = 'MULTI=1 SCPPROGRESS=1 PROGRAMS="${SBINCOMMANDS} ${BINCOMMANDS}"'
-DISTRO_TYPE = "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
+DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
do_debug_patch() {
if [ "${DISTRO_TYPE}" = "debug" ]; then
diff --git a/meta/recipes-core/dropbear/dropbear_0.52.bb b/meta/recipes-core/dropbear/dropbear_0.52.bb
index 78d6cf1c0b..4013c65074 100644
--- a/meta/recipes-core/dropbear/dropbear_0.52.bb
+++ b/meta/recipes-core/dropbear/dropbear_0.52.bb
@@ -3,4 +3,4 @@ require dropbear.inc
SRC_URI[md5sum] = "1c69ec674481d7745452f68f2ea5597e"
SRC_URI[sha256sum] = "e3a2ca49ed85ce562240c0ac06e2f72826d7e52a83e80d91c067c8b97bf5c108"
-PR = "r2"
+PR = "r3"