aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew Moseley <drew_moseley@mentor.com>2014-05-12 16:10:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-13 19:24:03 +0100
commitf38c1846184722180d9091a7a5c1e6e20eed7f2c (patch)
treee476039ea8bc5efc662e48deafe5682822fb6703
parent6fce92430e6e837d068eb8531dcd432f38adca3a (diff)
downloadopenembedded-core-contrib-f38c1846184722180d9091a7a5c1e6e20eed7f2c.tar.gz
mesa-demos: Specify the lib dir properly.
Use STAGING_EXECPREFIXDIR to specify the location of glut header files and libs rather than STAGING_LIBDIR. Also revert the previous unneeded change to glut.patch. Signed-off-by: Drew Moseley <drew_moseley@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos/glut.patch2
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos/glut.patch b/meta/recipes-graphics/mesa/mesa-demos/glut.patch
index 2ca5a938ac..84b6d4f7f3 100644
--- a/meta/recipes-graphics/mesa/mesa-demos/glut.patch
+++ b/meta/recipes-graphics/mesa/mesa-demos/glut.patch
@@ -27,7 +27,7 @@ Index: mesa-demos-8.0.1/configure.ac
- [glutInit],
- [],
- [glut_enabled=no])
-+ GLUT_LIBS="-L$withval -lglut"],
++ GLUT_LIBS="-L$withval/lib -lglut"],
+ [GLUT_CFLAGS=""
+ GLUT_LIBS="-lglut"]
+ )
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
index 211df3b249..7cda19eb6f 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
@@ -33,7 +33,7 @@ PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
-PACKAGECONFIG[glut] = "--with-glut=${STAGING_LIBDIR},--without-glut,"
+PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,"
PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libvg"
PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"