aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2014-05-12 15:55:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-13 19:24:02 +0100
commit00cbfadbf402ad1462ec0c8eaaaefa9a225a4aa7 (patch)
treed337345abaad36fbc3dcf68f8396967eb75b80cc
parent879ff7e931a80fd090db4485b6b6dee8e4c71d30 (diff)
downloadopenembedded-core-contrib-00cbfadbf402ad1462ec0c8eaaaefa9a225a4aa7.tar.gz
python: remove usage of FILESPATH
Fixes [YOCTO #4497] Usage of FILESPATH is discouraged, since it can make recipes harder to bbappend. Instead FILESEXTRAPATHS should be used to extend the path. Don't migrate paths that already exist in base FILESPATH to FILESEXTRAPATHS. Signed-off-by: Petter Mabäcker <petter@technux.se> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.3.bb2
-rw-r--r--meta/recipes-devtools/python/python-pygobject_2.28.3.bb1
2 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb
index 0c66d27c2d..b2a36b478f 100644
--- a/meta/recipes-devtools/python/python-native_2.7.3.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.3.bb
@@ -21,7 +21,7 @@ SRC_URI += "\
"
S = "${WORKDIR}/Python-${PV}"
-FILESPATH = "${FILE_DIRNAME}/python-native/:${FILE_DIRNAME}/python/"
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:"
inherit native
diff --git a/meta/recipes-devtools/python/python-pygobject_2.28.3.bb b/meta/recipes-devtools/python/python-pygobject_2.28.3.bb
index 9dbe47cfc9..2e65b3808a 100644
--- a/meta/recipes-devtools/python/python-pygobject_2.28.3.bb
+++ b/meta/recipes-devtools/python/python-pygobject_2.28.3.bb
@@ -16,7 +16,6 @@ SRC_URI[md5sum] = "aa64900b274c4661a5c32e52922977f9"
SRC_URI[sha256sum] = "7da88c169a56efccc516cebd9237da3fe518a343095a664607b368fe21df95b6"
S = "${WORKDIR}/pygobject-${PV}"
-FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
EXTRA_OECONF += "--disable-introspection"
PARALLEL_MAKEINST = ""