aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandr@xilinx.com>2018-01-09 16:23:52 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-20 22:31:12 +0000
commitc47b54aeae5daabb458d6f7118a16257021c1822 (patch)
tree97bb32e17623bab88527bc9eae458c3fde231791
parent65a85c7db3de8d16ff91a5208a59cc2202d34e5b (diff)
downloadopenembedded-core-contrib-c47b54aeae5daabb458d6f7118a16257021c1822.tar.gz
python3: Fix native compilation of gdbm module and manifest
The gdbm module wasnt being built on python3-native showing the following error during compilation: Failed to build these modules: _gdbm This patch adds the required dependency to fix the compilation problem. This issue on python3-native caused the manifest creation script to be unaware of the gdbm library, so this patch also fixes the create_manifest task for target python, and the manifest file to reflect the changes on target python as well. Signed-off-by: Alejandro Hernandez <alejandr@xilinx.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.3.bb2
-rw-r--r--meta/recipes-devtools/python/python3/python3-manifest.json15
2 files changed, 14 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.3.bb b/meta/recipes-devtools/python/python3-native_3.5.3.bb
index 3053c4bace..12f9f2404f 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.3.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.3.bb
@@ -38,7 +38,7 @@ UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
S = "${WORKDIR}/Python-${PV}"
EXTRANATIVEPATH += "bzip2-native"
-DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
+DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native gdbm-native"
inherit native
diff --git a/meta/recipes-devtools/python/python3/python3-manifest.json b/meta/recipes-devtools/python/python3/python3-manifest.json
index 92d0d00945..ef9826f02c 100644
--- a/meta/recipes-devtools/python/python3/python3-manifest.json
+++ b/meta/recipes-devtools/python/python3/python3-manifest.json
@@ -366,7 +366,8 @@
"db": {
"cached": [],
"files": [
- "${libdir}/python3.5/dbm"
+ "${libdir}/python3.5/dbm",
+ "${libdir}/python3.5/lib-dynload/_dbm.*.so"
],
"rdepends": [
"core"
@@ -493,6 +494,16 @@
],
"summary": "Python's fcntl interface"
},
+ "gdbm": {
+ "cached": [],
+ "files": [
+ "${libdir}/python3.5/lib-dynload/_gdbm.*.so"
+ ],
+ "rdepends": [
+ "core"
+ ],
+ "summary": "Python GNU database support"
+ },
"html": {
"cached": [
"${libdir}/python3.5/__pycache__/formatter.*.pyc"
@@ -1126,4 +1137,4 @@
],
"summary": "Python XML-RPC support"
}
-}
+} \ No newline at end of file