summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2019-05-27 21:27:32 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-29 12:53:46 +0100
commitb9b8cd3ce9755087d5d89b54287e171ac5effe3b (patch)
tree45fc8a13051d0a9599c50bc169e1f740df6d0f00
parent79582352f256673999ad3ae1c24a4602c5bcaf26 (diff)
downloadopenembedded-core-contrib-b9b8cd3ce9755087d5d89b54287e171ac5effe3b.tar.gz
perl: Preserve attributes when applying cross files
The file attributes (specifically the timestamps) must be preserved when applying the cross files to have reproducible builds. Otherwise, the cross files get the timestamp from when they are copied in the do_unpack task, and the reproducible_build class uses this timestamp since it is the youngest one in the source tree. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl-sanity/perl_5.28.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl-sanity/perl_5.28.2.bb b/meta/recipes-devtools/perl-sanity/perl_5.28.2.bb
index 12b220a4d8..f175e87a12 100644
--- a/meta/recipes-devtools/perl-sanity/perl_5.28.2.bb
+++ b/meta/recipes-devtools/perl-sanity/perl_5.28.2.bb
@@ -43,7 +43,7 @@ do_unpack_append() {
}
do_copy_perlcross() {
- cp -rf ${WORKDIR}/perl-cross*/* ${S}
+ cp -rfp ${WORKDIR}/perl-cross*/* ${S}
}
do_configure_class-target() {