aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 18:22:12 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2017-12-11 21:15:37 -0800
commit7e6b0af5063606561617ac428a90fc85a15fa38c (patch)
tree0ebd7f210187e71f5bc2a2ace3b5557bfcea88f2
parentb20a976178f3a68a615203b3996e06e5235e7ea9 (diff)
downloadopenembedded-core-contrib-7e6b0af5063606561617ac428a90fc85a15fa38c.tar.gz
python3-pip: use pypi.bbclass
* Simplify recipe by using pypi.bbclass Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb13
1 files changed, 3 insertions, 10 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
index 9b907a2631..4ce13da410 100644
--- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -1,22 +1,15 @@
SUMMARY = "The PyPA recommended tool for installing Python packages"
-sHOMEPAGEsss = "https://pypi.python.org/pypi/pip"
+HOMEPAGE = "https://pypi.python.org/pypi/pip"
SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452"
-SRCNAME = "pip"
DEPENDS += "python3 python3-setuptools-native"
-SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
SRC_URI[md5sum] = "35f01da33009719497f01a4ba69d63c9"
SRC_URI[sha256sum] = "09f243e1a7b461f654c26a725fa373211bb7ff17a9300058b205c61658ca940d"
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit distutils3
+inherit pypi distutils3
DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
@@ -33,7 +26,7 @@ do_install_append() {
rm ${D}/${bindir}/pip
# Installed eggs need to be passed directly to the interpreter via a pth file
- echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth
+ echo "./${PYPI_PACKAGE}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.pth
# Make sure we use /usr/bin/env python3
for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do