summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-27 05:56:28 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2017-11-27 05:56:28 -0800
commit84906e61a9ae8d824a1fa338eeadc01377470157 (patch)
tree9a0ff464c64a49e599221552133e3cf735c9eae9
parente4ce6c68aac46ee02da3b36c1f1431f762a25b5b (diff)
downloadopenembedded-core-contrib-84906e61a9ae8d824a1fa338eeadc01377470157.tar.gz
python-six: use pypi.bbclass
* Simplify python3-six by using pypi.bbclass - Use PYTHON_PN in .inc to avoid duplication in RDEPENDS Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-six.inc8
-rw-r--r--meta/recipes-devtools/python/python3-six_1.11.0.bb4
2 files changed, 4 insertions, 8 deletions
diff --git a/meta/recipes-devtools/python/python-six.inc b/meta/recipes-devtools/python/python-six.inc
index f9e7d6429d..aeac7e7e9f 100644
--- a/meta/recipes-devtools/python/python-six.inc
+++ b/meta/recipes-devtools/python/python-six.inc
@@ -4,13 +4,11 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=35cec5bf04dd0820d0a18533ea7c774a"
-SRC_URI = "https://files.pythonhosted.org/packages/source/s/six/six-${PV}.tar.gz"
SRC_URI[md5sum] = "d12789f9baf7e9fb2524c0c64f1773f8"
SRC_URI[sha256sum] = "70e8a77beed4562e7f14fe23a786b54f6296e34344c23bc42f07b15018ff98e9"
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/six/"
-UPSTREAM_CHECK_REGEX = "/six/(?P<pver>(\d+[\.\-_]*)+)"
+inherit pypi
-BBCLASSEXTEND = "native nativesdk"
+RDEPENDS_${PN} += "${PYTHON_PN}-io"
-S = "${WORKDIR}/six-${PV}"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-six_1.11.0.bb b/meta/recipes-devtools/python/python3-six_1.11.0.bb
index 38a47b77dd..9c41f94762 100644
--- a/meta/recipes-devtools/python/python3-six_1.11.0.bb
+++ b/meta/recipes-devtools/python/python3-six_1.11.0.bb
@@ -1,4 +1,2 @@
-inherit setuptools3
require python-six.inc
-
-RDEPENDS_${PN} += "python3-io"
+inherit setuptools3