summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-08-21 15:09:59 -0700
committerAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-11-24 15:57:43 -0800
commit36bc343fba2af2a640b526fc110c5a2f670b1252 (patch)
tree1b832a3fd9f0c9145a849a702b7868318054a34e
parent109cf74657c204cf746d67e968ff44cb58cc5c29 (diff)
downloadopenembedded-core-contrib-36bc343fba2af2a640b526fc110c5a2f670b1252.tar.gz
hwlatdetect: fix RDEPENDS to avoid QA failures
When listing python3 as an RDEPENDS, the image will in fact contain python3-modules, but the QA check fails to get RPROVIDERS correctly (since the python3 package does not actually exist), /usr/bin/python3 is provided by the python3-core package, so by fixing the RDEPENDS and listing python3-core instead of python3, the QA check works correctly and we avoid failures. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
index 60b44a4d25..5f61c4ecdd 100644
--- a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
@@ -22,5 +22,5 @@ do_install() {
}
FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
-RDEPENDS_${PN} = "python3 "
+RDEPENDS_${PN} = "python3-core "
RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"