summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2017-11-14 13:53:28 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-21 13:06:13 +0000
commit3213bda073ea858cbc4e09b2ee9bb6662140837a (patch)
tree76d8769129d9f170edd0aef04af4b5d09ca626da
parent22125f0ace2c355f7118de4ae797338f5863ce7f (diff)
downloadopenembedded-core-contrib-3213bda073ea858cbc4e09b2ee9bb6662140837a.tar.gz
net-tools: correctly set COPTS and LOPTS
COPTS will be ignored if it is defined in the environment. It must be passed directly to make. To be consistent, we pass LOPTS that way, too. (From OE-Core rev: dede6d3d37aab72ae897c3709d21108fa75f6673) Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-26.bb14
1 files changed, 3 insertions, 11 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
index c23d53376a..69c9af317d 100644
--- a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
@@ -81,20 +81,12 @@ do_configure() {
do_compile() {
# net-tools use COPTS/LOPTS to allow adding custom options
- export COPTS="$CFLAGS"
- export LOPTS="$LDFLAGS"
- unset CFLAGS
- unset LDFLAGS
-
- oe_runmake
+ oe_runmake COPTS="$CFLAGS" LOPTS="$LDFLAGS"
}
do_install() {
- export COPTS="$CFLAGS"
- export LOPTS="$LDFLAGS"
- unset CFLAGS
- unset LDFLAGS
- oe_runmake 'BASEDIR=${D}' install
+ # We don't need COPTS or LOPTS, but let's be consistent.
+ oe_runmake COPTS="$CFLAGS" LOPTS="$LDFLAGS" 'BASEDIR=${D}' install
if [ "${base_bindir}" != "/bin" ]; then
mkdir -p ${D}/${base_bindir}