aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 18:16:22 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 18:16:22 -0800
commitc5cd5550db5e9b3bc9954c9932bf9a7056d5f9f6 (patch)
tree352eac9b7eaad78e5c069af0d02132a0dc93cb85
parent3de1cd83b03267112d9b4f9297c8f5676c0ac264 (diff)
downloadopenembedded-core-contrib-c5cd5550db5e9b3bc9954c9932bf9a7056d5f9f6.tar.gz
libxml-sax-perl: inherit ptest-perl
* Enable ptest by inheriting new ptest-perl.bbclass * Install testfiles/ into PTEST_PATH Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_0.99.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
index ad31b9c9d2..cdcbebffce 100644
--- a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
+++ b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
@@ -23,6 +23,11 @@ SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6
S = "${WORKDIR}/XML-SAX-${PV}"
-inherit cpan
+inherit cpan ptest-perl
+
+do_install_ptest() {
+ cp -r ${B}/testfiles ${D}${PTEST_PATH}
+ chown -R root:root ${D}${PTEST_PATH}/testfiles
+}
BBCLASSEXTEND = "native"