aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 03:08:28 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 03:08:28 -0800
commit33ac1c7b856b09d1f12d7bbf13dd9343cf27a867 (patch)
treed793011f95a61bcb30d660c8f9d6d14bb8e1d685
parent2918d33de857ec94e839e09965cb8335307c3c31 (diff)
downloadopenembedded-core-contrib-33ac1c7b856b09d1f12d7bbf13dd9343cf27a867.tar.gz
libtest-needs-perl: add 0.002005
Skip tests when modules not available * Dependency for ptest of liburi-perl Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/perl/libtest-needs-perl_0.002005.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libtest-needs-perl_0.002005.bb b/meta/recipes-devtools/perl/libtest-needs-perl_0.002005.bb
new file mode 100644
index 0000000000..e5ab7a33c7
--- /dev/null
+++ b/meta/recipes-devtools/perl/libtest-needs-perl_0.002005.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Skip tests when modules not available"
+DESCRIPTION = "Skip test scripts if modules are not available. \
+The requested modules will be loaded, and optionally have their versions \
+checked. If the module is missing, the test script will be skipped. Modules \
+that are found but fail to compile will exit with an error rather than skip."
+
+HOMEPAGE = "https://metacpan.org/release/Test-Needs"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+CPAN_NAME = "Test-Needs"
+CPAN_AUTHOR = "HAARG"
+
+LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=81;endline=82"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://www.cpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "356634a56c99282e8059f290f5d534c8"
+SRC_URI[sha256sum] = "5a4f33983586edacdbe00a3b429a9834190140190dab28d0f873c394eb7df399"
+
+S = "${WORKDIR}/${CPAN_NAME}-${PV}"
+
+inherit cpan ptest-perl
+
+RDEPENDS_${PN}-ptest += "perl-module-test-more"
+
+BBCLASSEXTEND = "native"