aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 03:11:05 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 03:56:23 -0800
commit3f13984481fcfd6fba4b8191354d6c398b1554b2 (patch)
tree92761d7d9ee301887e08ca0b70344ef5e320aa71
parent3310f09cbf7dea7b4cf5d1f9d96222d1d772f120 (diff)
downloadopenembedded-core-contrib-3f13984481fcfd6fba4b8191354d6c398b1554b2.tar.gz
liburi-perl: inherit ptest-perl
* Enable ptest by inheriting new ptest-perl.bbclass * Remove t/cwd.t and t/file.t which require "-T" (taint) command line option as they will fail. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.73.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.73.bb b/meta/recipes-devtools/perl/liburi-perl_1.73.bb
index 7cdf6dc61d..49238f3df5 100644
--- a/meta/recipes-devtools/perl/liburi-perl_1.73.bb
+++ b/meta/recipes-devtools/perl/liburi-perl_1.73.bb
@@ -20,11 +20,19 @@ S = "${WORKDIR}/URI-${PV}"
EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
-inherit cpan
+inherit cpan ptest-perl
do_compile() {
export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
cpan_do_compile
}
+do_install_prepend() {
+ # these tests require "-T" (taint) command line option
+ rm -rf ${B}/t/cwd.t
+ rm -rf ${B}/t/file.t
+}
+
+RDEPENDS_${PN}-ptest += "libtest-needs-perl"
+
BBCLASSEXTEND = "native"