summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <joe.slater@windriver.com>2020-06-30 15:17:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-07-02 16:17:01 +0100
commitd2e6dbd7b3e30d144bf31cc8e287c8537ac25ebc (patch)
tree1e05ff90ab0b6944462fe99ebb75c3a0bab2f508
parent17c89ad1596dbc7cefdd2c01dcd95aa9e93c5dc6 (diff)
downloadopenembedded-core-contrib-d2e6dbd7b3e30d144bf31cc8e287c8537ac25ebc.tar.gz
jquery: use ${S}
Currently, several files are unpacked to WORKDIR and installed. This makes them invisible to the archiver. Unpack to S. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/jquery/jquery_3.5.1.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-devtools/jquery/jquery_3.5.1.bb b/meta/recipes-devtools/jquery/jquery_3.5.1.bb
index b4d7e80afe..62f0dfb0c5 100644
--- a/meta/recipes-devtools/jquery/jquery_3.5.1.bb
+++ b/meta/recipes-devtools/jquery/jquery_3.5.1.bb
@@ -2,12 +2,14 @@ SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library"
HOMEPAGE = "https://jquery.com/"
LICENSE = "MIT"
SECTION = "devel"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}.js;beginline=8;endline=10;md5=ebd7bc5d23ab165188e526a0c65d24bb"
+LIC_FILES_CHKSUM = "file://${S}/${BP}.js;beginline=8;endline=10;md5=ebd7bc5d23ab165188e526a0c65d24bb"
+# unpack items to ${S} so the archiver can see them
+#
SRC_URI = "\
- https://code.jquery.com/${BP}.js;name=js \
- https://code.jquery.com/${BP}.min.js;name=min \
- https://code.jquery.com/${BP}.min.map;name=map \
+ https://code.jquery.com/${BP}.js;name=js;subdir=${BP} \
+ https://code.jquery.com/${BP}.min.js;name=min;subdir=${BP} \
+ https://code.jquery.com/${BP}.min.map;name=map;subdir=${BP} \
"
SRC_URI[js.sha256sum] = "416a3b2c3bf16d64f6b5b6d0f7b079df2267614dd6847fc2f3271b4409233c37"
@@ -20,9 +22,9 @@ inherit allarch
do_install() {
install -d ${D}${datadir}/javascript/${BPN}/
- install -m 644 ${WORKDIR}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
- install -m 644 ${WORKDIR}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
- install -m 644 ${WORKDIR}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
+ install -m 644 ${S}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
+ install -m 644 ${S}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
+ install -m 644 ${S}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
}
PACKAGES = "${PN}"