aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Tworek <tworaz666@gmail.com>2012-03-06 09:03:13 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-08 11:48:39 -0800
commit34bdb9a459208377210454e54635afb9404ee126 (patch)
tree2d0e413d08b6542861591665fa1de5f8e5474fa2
parent40d7a4b70d342f75e13de7872fb62e2b9d6d40bf (diff)
downloadopenembedded-core-contrib-34bdb9a459208377210454e54635afb9404ee126.tar.gz
psplash: Add mising commands module import.
Python commands module is used in the recipe, but never imported. This leads to build errors like: NameError: global name 'commands' is not defined ERROR: The stack trace of python calls that resulted in this exception/failure was: ERROR: File "do_compile", line 24, in <module> ERROR: ERROR: File "do_compile", line 11, in do_compile ERROR: ERROR: The code that was being executed was: ERROR: 0020: bb.build.exec_func("oe_runmake", d) ERROR: 0021: shutil.copyfile("psplash", outputfile) ERROR: 0022: ERROR: 0023: ERROR: *** 0024:do_compile(d) ERROR: 0025: ERROR: (file: 'do_compile', lineno: 24, function: <module>) ERROR: 0007: localfiles = d.getVar('SPLASH_LOCALPATHS', True).split() ERROR: 0008: outputfiles = d.getVar('SPLASH_INSTALL', True).split() ERROR: 0009: for localfile, outputfile in zip(localfiles, outputfiles): ERROR: 0010: if localfile.endswith(".png"): ERROR: *** 0011: outp = commands.getstatusoutput('./make-image-header.sh %s POKY' % localfile) ERROR: 0012: print(outp[1]) ERROR: 0013: fbase = os.path.splitext(os.path.basename(localfile))[0] ERROR: 0014: shutil.copyfile("%s-img.h" % fbase, destfile) ERROR: 0015: else: Signed-off-by: Peter Tworek <tworaz666@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 42ea6151e5..bd405f965d 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -68,7 +68,7 @@ S = "${WORKDIR}/git"
inherit autotools pkgconfig update-rc.d
python do_compile () {
- import shutil
+ import shutil, commands
# Build a separate executable for each splash image
destfile = "%s/psplash-poky-img.h" % d.getVar('S', True)