summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schoepfer <matthias.schoepfer@ithinx.io>2020-03-30 11:41:11 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-30 14:52:43 +0100
commit6beab388e73b3ac6157650855a6c1fb1d71e8015 (patch)
tree238bbaa41a23fc3e9f558f5114e481b4957ba093
parente7f025c87d595d2e37f83b75f11bedf2bce7bcc0 (diff)
downloadopenembedded-core-contrib-6beab388e73b3ac6157650855a6c1fb1d71e8015.tar.gz
python3: fixing bpo-36852 patch for builds on i686 architecture
The original patch "bpo-36852: proper detection of mips architecture for soft float" uses AC_CANONICAL_TARGET to determine the platform triplet. While AC_CANONICAL_TARGET exports i686 as target_cpu, gcc is using i386 instead. We fall back here to i386, as it is conform to the previous behavior. Upstream Status: Submitted [https://github.com/python/cpython/pull/13196] Signed-off-by: Matthias Schoepfer <matthias.schoepfer@ithinx.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3/0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch20
1 files changed, 14 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python3/0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch b/meta/recipes-devtools/python/python3/0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch
index fe0aa8aabe..c4fae09a5b 100644
--- a/meta/recipes-devtools/python/python3/0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch
+++ b/meta/recipes-devtools/python/python3/0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch
@@ -1,4 +1,4 @@
-From 2581ebe3cd9686089aed223651e1b8bf0b862b48 Mon Sep 17 00:00:00 2001
+From 1ad771d86728ee2ed30e202e9768d8d825f96467 Mon Sep 17 00:00:00 2001
From: Matthias Schoepfer <matthias.schoepfer@ithinx.io>
Date: Fri, 31 May 2019 15:34:34 +0200
Subject: [PATCH] bpo-36852: proper detection of mips architecture for soft
@@ -13,15 +13,16 @@ to do this in a more autoconf/autotools manner.
Upstream-Status: Submitted [https://github.com/python/cpython/pull/13196]
Signed-off-by: Matthias Schoepfer <matthias.schoepfer@ithinx.io>
+%% original patch: 0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch
---
- configure.ac | 171 +++++----------------------------------------------
- 1 file changed, 17 insertions(+), 154 deletions(-)
+ configure.ac | 175 +++++++--------------------------------------------
+ 1 file changed, 21 insertions(+), 154 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 0f85486..0ca7e24 100644
+index ede710e..bc81b0b 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -704,160 +704,23 @@ fi
+@@ -710,160 +710,27 @@ fi
MULTIARCH=$($CC --print-multiarch 2>/dev/null)
AC_SUBST(MULTIARCH)
@@ -193,9 +194,16 @@ index 0f85486..0ca7e24 100644
+ PLATFORM_TRIPLET=vxworks
+ ;;
+ *)
-+ PLATFORM_TRIPLET=${target_cpu}-${target_os}
++ if test "${target_cpu}" != "i686"; then
++ PLATFORM_TRIPLET=${target_cpu}-${target_os}
++ else
++ PLATFORM_TRIPLET=i386-${target_os}
++ fi
+ ;;
+esac
if test x$PLATFORM_TRIPLET != x && test x$MULTIARCH != x; then
if test x$PLATFORM_TRIPLET != x$MULTIARCH; then
+--
+2.24.1
+