summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2020-03-27 17:25:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-30 12:33:24 +0100
commitfb64a50c3ab385d5bfd33dd669b6148e43b43770 (patch)
tree4946e0f7d3b3f74598283f4dbf29dd486107d42e
parentcd6bab044288779a67b94353ff91935f59bfcb56 (diff)
downloadopenembedded-core-contrib-fb64a50c3ab385d5bfd33dd669b6148e43b43770.tar.gz
systemd: Use PACKAGE_BEFORE_PN, not =+
By using PACKAGE_BEFORE_PN rather than =+ it's clearer how we expect the package ordering to work. It also avoids the possibilty that dev/dbg/etc. artefacts attempt to package as part of these packages. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_244.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/systemd/systemd_244.3.bb b/meta/recipes-core/systemd/systemd_244.3.bb
index d30b5b4e14..e1c4debdec 100644
--- a/meta/recipes-core/systemd/systemd_244.3.bb
+++ b/meta/recipes-core/systemd/systemd_244.3.bb
@@ -307,7 +307,7 @@ python populate_packages_prepend (){
}
PACKAGES_DYNAMIC += "^lib(udev|systemd|nss).*"
-PACKAGES =+ "\
+PACKAGE_BEFORE_PN = "\
${PN}-gui \
${PN}-vconsole-setup \
${PN}-initramfs \
@@ -321,6 +321,8 @@ PACKAGES =+ "\
${PN}-journal-upload \
${PN}-journal-remote \
${PN}-extra-utils \
+ udev \
+ udev-hwdb \
"
SUMMARY_${PN}-container = "Tools for containers and VMs"
@@ -580,8 +582,6 @@ INSANE_SKIP_${PN} += "dev-so libdir"
INSANE_SKIP_${PN}-dbg += "libdir"
INSANE_SKIP_${PN}-doc += " libdir"
-PACKAGES =+ "udev udev-hwdb"
-
RPROVIDES_udev = "hotplug"
RDEPENDS_udev-hwdb += "udev"