summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-03-27 19:07:25 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2020-03-31 10:52:01 -0700
commit285241372af043a6a265cc840be7f983c1c7ffcf (patch)
tree9adad26259a4010344f9051c1ccad86ddb012f53
parent41785e998bc2afea606e212723747927bb9249d3 (diff)
downloadopenembedded-core-contrib-285241372af043a6a265cc840be7f983c1c7ffcf.tar.gz
openembedded-core-contrib-285241372af043a6a265cc840be7f983c1c7ffcf.tar.bz2
openembedded-core-contrib-285241372af043a6a265cc840be7f983c1c7ffcf.zip
oe-buildenv-internal: python 3.5 as min version
Python 3.4 is EOL: https://www.python.org/downloads/release/python-3410/ The last supported distro was probably CentOS-7, which has python36 available from epel-7 or scl (as rh-python36) [1] [1] https://www.softwarecollections.org/en/scls/rhscl/rh-python36/ Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rwxr-xr-xscripts/oe-buildenv-internal8
1 files changed, 4 insertions, 4 deletions
diff --git a/scripts/oe-buildenv-internal b/scripts/oe-buildenv-internal
index 8cbe34669d..c62688fbd2 100755
--- a/scripts/oe-buildenv-internal
+++ b/scripts/oe-buildenv-internal
@@ -32,12 +32,12 @@ fi
# We potentially have code that doesn't parse correctly with older versions
# of Python, and rather than fixing that and being eternally vigilant for
# any other new feature use, just check the version here.
-py_v34_check=$(python3 -c 'import sys; print(sys.version_info >= (3,4,0))')
-if [ "$py_v34_check" != "True" ]; then
- echo >&2 "BitBake requires Python 3.4.0 or later as 'python3'"
+py_v35_check=$(python3 -c 'import sys; print(sys.version_info >= (3,5,0))')
+if [ "$py_v35_check" != "True" ]; then
+ echo >&2 "BitBake requires Python 3.5.0 or later as 'python3'"
return 1
fi
-unset py_v34_check
+unset py_v35_check
if [ -z "$BDIR" ]; then
if [ -z "$1" ]; then