aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2014-06-25 11:13:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-25 13:51:09 +0100
commitb4cd268cf7506a521d7800112cb775bd49e1ef09 (patch)
tree12d785073afa06701c6af940797f15bc3ab31fee
parent3ec0f411985cf6891b34e1f9624df9df38c9fc6f (diff)
downloadopenembedded-core-contrib-b4cd268cf7506a521d7800112cb775bd49e1ef09.tar.gz
u-boot-fw-utils: install config file
The on-target fw_printenv and fw_setenv needs configuration file (fw_env.config) to be present in the target. Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
index 14b09761e1..89fed8bee4 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
@@ -26,8 +26,10 @@ do_compile () {
do_install () {
install -d ${D}${base_sbindir}
+ install -d ${D}${sysconfdir}
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
}
PACKAGE_ARCH = "${MACHINE_ARCH}"