summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-11-24 09:08:13 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-25 21:53:44 +0000
commitf72df428904921cb87223de4e72e784e97208e8f (patch)
tree47f36c84bdc70ece53976737491a7a8616cda5f8
parent82288f0b1eb3189d14a006d2fa1844bc9d6303c1 (diff)
downloadopenembedded-core-contrib-f72df428904921cb87223de4e72e784e97208e8f.tar.gz
ell: remove unneeded patch
Upstream added internal implementation shortly after the patch was added. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/ell/ell/0001-pem.c-do-not-use-rawmemchr.patch27
-rw-r--r--meta/recipes-core/ell/ell_0.45.bb1
2 files changed, 0 insertions, 28 deletions
diff --git a/meta/recipes-core/ell/ell/0001-pem.c-do-not-use-rawmemchr.patch b/meta/recipes-core/ell/ell/0001-pem.c-do-not-use-rawmemchr.patch
deleted file mode 100644
index f0ce6f1364..0000000000
--- a/meta/recipes-core/ell/ell/0001-pem.c-do-not-use-rawmemchr.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 277e1eca67fcc23cb31be7b826d83a19d9b89bd2 Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Tue, 22 Dec 2020 10:30:54 +0000
-Subject: [PATCH] pem.c: do not use rawmemchr()
-
-This is a glibc-only function, and causes build failures with
-alternative libc implementations such as musl.
-
-Upstream-Status: Pending
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- ell/pem.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ell/pem.c b/ell/pem.c
-index 790f2c2..237ae02 100644
---- a/ell/pem.c
-+++ b/ell/pem.c
-@@ -224,7 +224,7 @@ static uint8_t *pem_load_buffer(const void *buf, size_t buf_len,
-
- /* Check that each header line has a key and a colon */
- while (start < end) {
-- const char *lf = rawmemchr(start, '\n');
-+ const char *lf = memchr(start, '\n', end - start);
- const char *colon = memchr(start, ':', lf - start);
-
- if (!colon)
diff --git a/meta/recipes-core/ell/ell_0.45.bb b/meta/recipes-core/ell/ell_0.45.bb
index 8453720f42..64434c278c 100644
--- a/meta/recipes-core/ell/ell_0.45.bb
+++ b/meta/recipes-core/ell/ell_0.45.bb
@@ -15,7 +15,6 @@ DEPENDS = "dbus"
inherit autotools pkgconfig
SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
- file://0001-pem.c-do-not-use-rawmemchr.patch \
"
SRC_URI[sha256sum] = "fedfcceee56eb63ab1eb98bf120a3cfbecee50bcd893874328c889f1b381e7d7"