aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-05-28 18:59:54 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-29 10:32:29 +0100
commit15bdef1f25ef567caf2f2e270de899e35da7cca9 (patch)
tree3b28c4d013fbcbc332ddfda7414cf09a9fd10541
parent9e03db2dfab0b534b86fd48c9190b2d7d0d21238 (diff)
downloadopenembedded-core-contrib-15bdef1f25ef567caf2f2e270de899e35da7cca9.tar.gz
ethtool: use serial-tests config needed by ptest.
buildtest-TESTS and runtest-TESTS targets are required by ptest. In order to have those targets in automake 1.13.4 serial-tests should be specified since parallel-tests is assumed by default and serial-tests is optional. ptest results: PASS: test-cmdline PASS: test-features ================== All 2 tests passed ================== Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch19
-rw-r--r--meta/recipes-extended/ethtool/ethtool_3.14.bb6
2 files changed, 23 insertions, 2 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
new file mode 100644
index 0000000000..bf66267e81
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
@@ -0,0 +1,19 @@
+ptest needs buildtest-TESTS and runtest-TESTS targets.
+serial-tests is required to generate those targets.
+
+Signed-off-by: Tudor Florea <tudor.florea@enea.com>
+Upstream-Status: Inappropriate
+(default automake behavior incompatible with ptest)
+
+diff -ruN a/configure.ac b/configure.ac
+--- a/configure.ac 2014-05-28 18:19:13.513980977 +0200
++++ b/configure.ac 2014-05-28 18:19:21.129660215 +0200
+@@ -2,7 +2,7 @@
+ AC_INIT(ethtool, 3.14, netdev@vger.kernel.org)
+ AC_PREREQ(2.52)
+ AC_CONFIG_SRCDIR([ethtool.c])
+-AM_INIT_AUTOMAKE([gnu])
++AM_INIT_AUTOMAKE([gnu serial-tests])
+ AC_CONFIG_HEADERS([ethtool-config.h])
+
+ AM_MAINTAINER_MODE
diff --git a/meta/recipes-extended/ethtool/ethtool_3.14.bb b/meta/recipes-extended/ethtool/ethtool_3.14.bb
index 2a3ca7022f..49c79b68d7 100644
--- a/meta/recipes-extended/ethtool/ethtool_3.14.bb
+++ b/meta/recipes-extended/ethtool/ethtool_3.14.bb
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
- file://run-ptest"
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ "
SRC_URI[md5sum] = "997e20c25c43ad5800f8ae3204455a8a"
SRC_URI[sha256sum] = "b1a988d6e397bd9d5d73cfd64329f85121936a050174bbfe90f8701fd893a1df"
@@ -16,7 +18,7 @@ inherit autotools ptest
RDEPENDS_${PN}-ptest += "make"
do_compile_ptest() {
- oe_runmake test-cmdline test-features
+ oe_runmake buildtest-TESTS
}
do_install_ptest () {