aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2014-08-11 09:15:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 17:43:33 +0100
commit7216ddad59f6a2315323befa69eebdbf07625e25 (patch)
tree7d836c4155768cdb3c01f0252a9697ec9b871181
parent63cbed337241191f33fe951662a39ce59dce6774 (diff)
downloadopenembedded-core-contrib-7216ddad59f6a2315323befa69eebdbf07625e25.tar.gz
python-dbus: use PACKAGECONFIG for doc generation
Adds 'docs' (for html doc generation) and 'api-docs' (for API doc generation) configurations and leaves them both disabled by default. This avoids autodetected dependency upon docutils. Fixes [YOCTO #6530] Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-dbus_1.2.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-dbus_1.2.0.bb b/meta/recipes-devtools/python/python-dbus_1.2.0.bb
index e64f99f87a..b314dce1c7 100644
--- a/meta/recipes-devtools/python/python-dbus_1.2.0.bb
+++ b/meta/recipes-devtools/python/python-dbus_1.2.0.bb
@@ -14,6 +14,10 @@ S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils-base autotools pkgconfig
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python-docutils-native"
+PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python-docutils-native python-epydoc-native"
+
export BUILD_SYS
export HOST_SYS