summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mhatle@windriver.com>2010-08-06 11:40:55 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-12 15:47:02 +0100
commit1c9f061d1f855cd0ecdcd3449e1f9bf45a7de0ee (patch)
tree0512b90ff03277fc90a7803ae5a271b704fb9696
parente101642a61fc418273c1cd4d58a9564b4bdecc5c (diff)
downloadopenembedded-core-contrib-1c9f061d1f855cd0ecdcd3449e1f9bf45a7de0ee.tar.gz
pseudo: Upgrade pseudo and correct problems
Fix an issue where pseudo could try to compile incorrectly on an x86_64 host system. Now it verifies that it should be trying to build a 32-bit library, and if so the necessary prereqs are available. Also uprev to the latest version of pseudo changes to enable wrapping of execl, local variable storage and misc fixes. Signed-off-by: Mark Hatle <mhatle@windriver.com>
-rw-r--r--meta/classes/sanity.bbclass5
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc2
-rw-r--r--meta/packages/pseudo/pseudo_git.bb6
3 files changed, 9 insertions, 4 deletions
diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 31b8dd2b07..a595224a7f 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -143,6 +143,11 @@ def check_sanity(e):
if data.getVar('SDK_ARCH', e.data, True) == 'i686':
messages = messages + '"Please set SDKMACHINE to i586. It is currently defaulting to the build machine architecture of i686 and this is known to have issues (see local.conf).\n'
+ nolibs = data.getVar('NO32LIBS', e.data, True)
+ if not nolibs:
+ if os.path.exists('/lib/libc.so.6') and not os.path.exists('/usr/include/gnu/stubs-32.h'):
+ messages = messages + "You have a 32-bit libc, but no 32-bit headers. You must install the 32-bit libc headers.\n"
+
#
# Check that TMPDIR hasn't changed location since the last time we were run
#
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index fe3e8bbf08..190296abf3 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -110,7 +110,7 @@ PRELINKSRCREV ??= "909470ee441237563d6236c505cb2d02ddc48704"
SRCREV_pn-prelink ??= "${PRELINKSRCREV}"
SRCREV_pn-prelink-native ??= "${PRELINKSRCREV}"
SRCREV_pn-psplash ??= "424"
-PSEUDOSRCREV ??= "551bf567c171c9f6f475f02de80e35df9563dce7"
+PSEUDOSRCREV ??= "5d027f78a6e677e9272a17555a83124026e6fb08"
SRCREV_pn-pseudo ??= "${PSEUDOSRCREV}"
SRCREV_pn-pseudo-native ??= "${PSEUDOSRCREV}"
QEMUSRCREV ??= "72bb3c7571226af13cfe9eec020a56add3d30a70"
diff --git a/meta/packages/pseudo/pseudo_git.bb b/meta/packages/pseudo/pseudo_git.bb
index d393967ceb..eac398ed12 100644
--- a/meta/packages/pseudo/pseudo_git.bb
+++ b/meta/packages/pseudo/pseudo_git.bb
@@ -6,7 +6,7 @@ LICENSE = "LGPL2.1"
DEPENDS = "sqlite3"
PV = "0.0+git${SRCPV}"
-PR = "r12"
+PR = "r13"
SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
file://static_sqlite.patch"
@@ -26,8 +26,8 @@ do_compile () {
if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" ]; then
# We need the 32-bit libpseudo on a 64-bit machine...
./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32
- oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib'
- # prevent it from removing the lib, but keep everything else
+ oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib' libpseudo
+ # prevent it from removing the lib, but remove everything else
make 'LIB=foo' distclean
fi
${S}/configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=${SITEINFO_BITS}