summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuslan Bilovol <rbilovol@cisco.com>2020-03-05 13:53:33 +0200
committerArmin Kuster <akuster808@gmail.com>2020-04-19 17:15:54 -0700
commit969146b0cc4b49d313d43600acc9b4906c183717 (patch)
tree8bdda16b25950032c032e2c3044db5cf88b94082
parentab4daefc65f60924286cb0448c020f59fb5145eb (diff)
downloadopenembedded-core-contrib-969146b0cc4b49d313d43600acc9b4906c183717.tar.gz
openssl: pass PERL=perl environment variable to configurator
In our build environment we use wrapper script for perl in non-standard configuration with extra variables set (provided by custom buildtools-tarball). In this case openssl fails to build because by default it's Configure script detects and uses perl executable directly (with absolute path) obviously missing extra settings from wrapper script. Pass PERL=perl environment variable to Configure, so it won't try to use perl executable directly but will use what is provided from environment. Signed-off-by: Ruslan Bilovol <rbilovol@cisco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 2b087fef6820da8a6d86ca763bd7730dcac30849) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.1d.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.1d.bb b/meta/recipes-connectivity/openssl/openssl_1.1.1d.bb
index 169824a8be..e34f816a4d 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.1d.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.1d.bb
@@ -120,7 +120,7 @@ do_configure () {
fi
# WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
# environment variables set by bitbake. Adjust the environment variables instead.
- PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
+ PERL=perl PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
perl ${S}/Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} --prefix=$useprefix --openssldir=${libdir}/ssl-1.1 --libdir=${libdir} $target
perl ${B}/configdata.pm --dump
}