summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-07 14:33:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-11 23:04:29 +0000
commitbde90e407c8ae0b851534ae84d9d54980e908046 (patch)
treef7098a144c8ff4990ab43ff485c88e92cb20a325
parent232430bdee74bb266ded6ccf2fb3842caad06181 (diff)
downloadopenembedded-core-contrib-bde90e407c8ae0b851534ae84d9d54980e908046.tar.gz
sysvinit: Fix Reproducibility issue
With a sequence like: bitbake sysvinit bitbake sysvinit -c clean bitbake sysvinit -c package_write_ipk -f then the resulting package has two files with group "root/70" rather than "root/shutdown". The issue is that of do_package is a setscene task, base-passwd isn't present. This patch fixes that dependency but there may be other cases of this problem around. [YOCTO #13776] (From OE-Core rev: 0227e929021263c51d2e7db36224000fecb01f1c) (From OE-Core rev: cbcba43c18d67aea0ba41f019b357fbec6570ee1) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
index bfc1283f73..39f612be1f 100644
--- a/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
@@ -31,6 +31,7 @@ B = "${S}/src"
inherit update-alternatives distro_features_check
DEPENDS_append = " update-rc.d-native base-passwd virtual/crypt"
+do_package_setscene[depends] = "${MLPREFIX}base-passwd:do_populate_sysroot"
REQUIRED_DISTRO_FEATURES = "sysvinit"