aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2016-11-21 11:04:20 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:10 +0000
commitf09e0d857ae917f0a0b393374fb8d6de5a1926e6 (patch)
tree538b61a624cdebab3cf2c0771bee865d1e4d9dd4
parent97e0bf4e1c79077a0f6dc25e0b8888506481f536 (diff)
downloadopenembedded-core-contrib-f09e0d857ae917f0a0b393374fb8d6de5a1926e6.tar.gz
libxml-parser-perl: add expat/Makefile dependency
The file Expat.bs (which is empty!) is created by BOOTSTRAP, but is deleted by INST_DYNAMIC. Make sure we are not creating and deleting it at the same time. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
index 3acd826868..ab9e5faa51 100644
--- a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
@@ -20,6 +20,8 @@ inherit cpan
do_configure_append() {
sed 's:--sysroot=.*\(\s\|$\):--sysroot=${STAGING_DIR_TARGET} :g' -i Makefile Expat/Makefile
sed 's:^FULL_AR = .*:FULL_AR = ${AR}:g' -i Expat/Makefile
+ # make sure these two do not build in parallel
+ sed 's!^$(INST_DYNAMIC):!$(INST_DYNAMIC): $(BOOTSTRAP)!' -i Expat/Makefile
}
do_compile() {