summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-04 14:01:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-05 11:40:56 +0000
commit768766dc007ebe9b4bc38d425584be03fbdb98c1 (patch)
treeff8272b65479e3638f2474cc67a54b7d10509b81
parent2ac647ca63e240f982d08a8b538648f602071cd9 (diff)
downloadopenembedded-core-contrib-768766dc007ebe9b4bc38d425584be03fbdb98c1.tar.gz
opkg: Fix poor operator combination choice
Combining :append with += rarely makes sense. Improve it to use the standard format (and tweak the implied spacing). Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.4.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.4.5.bb b/meta/recipes-devtools/opkg/opkg_0.4.5.bb
index f5c7d11191..1fe6ed5ecb 100644
--- a/meta/recipes-devtools/opkg/opkg_0.4.5.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.4.5.bb
@@ -60,7 +60,7 @@ do_install_ptest () {
sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile
}
-WARN_QA:append += "openssl-deprecation"
+WARN_QA:append = " openssl-deprecation"
QAPKGTEST[openssl-deprecation] = "package_qa_check_openssl_deprecation"
def package_qa_check_openssl_deprecation (package, d, messages):
sane = True