aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenbo Gao <zhenbo.gao@windriver.com>2016-07-05 16:25:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-08 09:55:40 +0100
commit2004307044e958cdf508b72f180e238a3e297179 (patch)
tree6222e40986cfc02169e626a613db0cd79cda7f35
parent0b2945588f7b539836369895dc7d3d2629abb431 (diff)
downloadopenembedded-core-contrib-2004307044e958cdf508b72f180e238a3e297179.tar.gz
autogen-native: fix script error when processing libguile
do_configure for autogen-native would fail if build directory path contains '-I' characters, which is caused by the unsuitable sed script when processing libguile. Error log: [snip] checking for GUILE... yes awk: fatal: cannot open file `/buildarea1/poky/build /libguile/version.h' for reading (No such file or directory) configure: error: in `/buildarea1/poky/build-Ice/tmp/work/x86_64-linux/autogen-native/5.18.10-r0/build': configure: error: cannot determine Guile version [snip] Signed-off-by: Zhenbo Gao <zhenbo.gao@windriver.com> Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.10.bb1
-rw-r--r--meta/recipes-devtools/autogen/autogen/fix-script-err-when-processing-libguile.patch37
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.10.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.10.bb
index fd52c83bd0..274427c7e9 100644
--- a/meta/recipes-devtools/autogen/autogen-native_5.18.10.bb
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.10.bb
@@ -11,6 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
file://increase-timeout-limit.patch \
file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch \
+ file://fix-script-err-when-processing-libguile.patch \
"
SRC_URI[md5sum] = "2d1b5226e1929d0680011df631289571"
diff --git a/meta/recipes-devtools/autogen/autogen/fix-script-err-when-processing-libguile.patch b/meta/recipes-devtools/autogen/autogen/fix-script-err-when-processing-libguile.patch
new file mode 100644
index 0000000000..694a3953ea
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen/fix-script-err-when-processing-libguile.patch
@@ -0,0 +1,37 @@
+autogen-native: fix script err when processing libguile
+
+do_configure for autogen will fail if project directory path
+contains '-I' character, which is caused by the unsuitable sed
+script when processing libguile.
+
+Upstream-Status: Pending
+
+Signed-off-by: Zhenbo Gao <zhenbo.gao@windriver.com>
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+
+diff --git a/config/ag_macros.m4 b/config/ag_macros.m4
+index 58186b6..58ed2ad 100644
+--- a/config/ag_macros.m4
++++ b/config/ag_macros.m4
+@@ -32,7 +32,7 @@ AC_DEFUN([INVOKE_AG_MACROS_LAST],[
+ GUILE_FLAGS
+ [ag_gv=`gdir=\`pkg-config --cflags-only-I \
+ guile-${GUILE_EFFECTIVE_VERSION} | \
+- sed 's/-I *//;s/ *-I.*/ /g'\`
++ sed 's/ *-I *\// \//g'\`
+ for d in $gdir
+ do test -f "$d/libguile/version.h" && gdir=$d && break
+ done
+diff --git a/config/misc.def b/config/misc.def
+index 490d361..6e183ef 100644
+--- a/config/misc.def
++++ b/config/misc.def
+@@ -342,7 +342,7 @@ do-always = <<- _END_ALWAYS_
+ GUILE_FLAGS
+ [ag_gv=`gdir=\`pkg-config --cflags-only-I \
+ guile-${GUILE_EFFECTIVE_VERSION} | \
+- sed 's/-I *//;s/ *-I.*/ /g'\`
++ sed 's/ *-I *\// \//g'\`
+ test -z "$gdir" && gdir=/usr/include
+ for d in $gdir
+ do test -f "$d/libguile/version.h" && gdir=$d && break