summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-06-13 15:30:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-14 10:03:58 +0100
commitdd39446dff75c6e48f4aa44ec90087f172d717d4 (patch)
treeb775a4f115e79bf72d00be5fa05b842d9444f990
parent8beef93e6e341566eba8a125f75ad836ac6a3d69 (diff)
downloadopenembedded-core-contrib-dd39446dff75c6e48f4aa44ec90087f172d717d4.tar.gz
python3-cryptography: remove test_x509.py
We already have removed --benchmark-disable option to avoid adding python3-pytest-benchmark rdepends. Also remove the case test_x509.py which needs benchmark feature to avoid below failure: file /usr/lib64/python3-cryptography/ptest/tests/bench/test_x509.py, line 9 def test_aki_public_bytes(benchmark): > fixture 'benchmark' not found > available fixtures: backend, cache, capfd, capfdbinary, caplog, capsys, capsysbinary, disable_rsa_checks, doctesty > use 'pytest --fixtures [testpath]' for help on them. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-cryptography_37.0.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb b/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
index d7a720bf2b..470cf4388c 100644
--- a/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
+++ b/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
@@ -104,6 +104,9 @@ do_install_ptest() {
install -D ${WORKDIR}/check-memfree.py ${D}${PTEST_PATH}/
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ # remove test_x509.py as it needs benchmark and we don't
+ # want to introduce the benchmark dependency
+ rm -rf ${D}${PTEST_PATH}/tests/bench/test_x509.py
install -d ${D}${PTEST_PATH}/tests/hazmat
cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
cp -r ${S}/pyproject.toml ${D}${PTEST_PATH}/