summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Villemoes <rasmus.villemoes@prevas.dk>2022-06-08 09:42:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-08 21:55:45 +0100
commit06ed2aa93fc25a681e3a00ee120d9395b04845da (patch)
treea8f5eac13f32a1f787450903b4a580f981aecb25
parentf9dd8ee063c1132265248457fcd628e1e93727be (diff)
downloadopenembedded-core-contrib-06ed2aa93fc25a681e3a00ee120d9395b04845da.tar.gz
vim: put xxd in its own package
The xxd tool can be quite handy by itself, and doesn't have anything to do with vim per se. Make it possible to include the rather tiny xxd in a rootfs without pulling in the several MB vim binary and associated data. For backwards compatibility, add an RDEPENDS from the main package to the new vim-xxd package. Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/vim/vim_8.2.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-support/vim/vim_8.2.bb b/meta/recipes-support/vim/vim_8.2.bb
index f358e61132..fee9f055e9 100644
--- a/meta/recipes-support/vim/vim_8.2.bb
+++ b/meta/recipes-support/vim/vim_8.2.bb
@@ -2,14 +2,18 @@ require vim.inc
PROVIDES = "xxd"
-RDEPENDS:${PN} = "ncurses-terminfo-base"
+RDEPENDS:${PN} = "ncurses-terminfo-base ${PN}-xxd"
# Recommend that runtime data is installed along with vim
RRECOMMENDS:${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
PACKAGECONFIG:class-native = ""
BBCLASSEXTEND = "native nativesdk"
-ALTERNATIVE:${PN}:append = " xxd"
+PACKAGES =+ "${PN}-xxd"
+FILES:${PN}-xxd = "${bindir}/xxd"
+RPROVIDES:${PN}-xxd = "xxd"
+
+ALTERNATIVE:${PN}-xxd = "xxd"
ALTERNATIVE_TARGET[xxd] = "${bindir}/xxd"
ALTERNATIVE_LINK_NAME[xxd] = "${bindir}/xxd"