aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-07-20 23:36:47 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-09-23 01:45:36 -0700
commit3d19fbef1c4044e3e0418a71fae1fbb83a43f7d2 (patch)
tree465133eb79bbe027c3aacff8c8db5c3621c44a1f
parent9cf3619d3acaf28575e85e9e724c818e87fe560c (diff)
downloadopenembedded-core-contrib-3d19fbef1c4044e3e0418a71fae1fbb83a43f7d2.tar.gz
libinput: fix udevdir
* Use "pkg-config --variable=udevdir udev" to fix udevdir, otherwise it would use ${libdir}/udev which is incorrect for systemd's udev. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.4.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.4.1.bb b/meta/recipes-graphics/wayland/libinput_1.4.1.bb
index c3905f3d9a..3580392260 100644
--- a/meta/recipes-graphics/wayland/libinput_1.4.1.bb
+++ b/meta/recipes-graphics/wayland/libinput_1.4.1.bb
@@ -20,4 +20,6 @@ PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
PACKAGECONFIG[libwacom] = "--enable-libwacom,--disable-libwacom,libwacom"
PACKAGECONFIG[gui] = "--enable-event-gui,--disable-event-gui,cairo gtk+3"
-FILES_${PN} += "${libdir}/udev/"
+UDEVDIR = "`pkg-config --variable=udevdir udev`"
+
+EXTRA_OECONF += "--with-udev-dir=${UDEVDIR}"