aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-04-07 00:34:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-08 08:00:42 +0100
commitfc4d721e047989a3521267e26de123759741ffa3 (patch)
tree2dd4653227e4a6e9302aa77f9119ee516d8acb4e
parent23c375198d73a5dec4646b04e3fd1d4cb005565a (diff)
downloadopenembedded-core-contrib-fc4d721e047989a3521267e26de123759741ffa3.tar.gz
libsolv: fix installed-vs-shipped for nativesdk
Fixed: ERROR: nativesdk-libsolv-0.6.19-r0 do_package: QA Issue: nativesdk-libsolv: Files/directories were installed but not shipped in any package: /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man3 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man1 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man3/libsolv-constantids.3 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man3/libsolv.3 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man3/libsolv-history.3 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man3/libsolv-pool.3 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man3/libsolv-bindings.3 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man1/mergesolv.1 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man1/testsolv.1 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man1/installcheck.1 /opt/poky/2.0+snapshot/sysroots/x86_64-pokysdk-linux/usr/man/man1/dumpsolv.1 It checks ${CMAKE_INSTALL_PREFIX}/share/man when configure, but it may not exist when crosscompile, for example, when CMAKE_INSTALL_PREFIX="/", it is OK, but when CMAKE_INSTALL_PREFIX="/some/path/else", then it doesn't exist, and the man dir would be set to "/usr/man" which is incorrect. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/libsolv/libsolv/0001-CMakeLists.txt-fix-MAN_INSTALL_DIR.patch37
-rw-r--r--meta/recipes-extended/libsolv/libsolv_git.bb4
2 files changed, 40 insertions, 1 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv/0001-CMakeLists.txt-fix-MAN_INSTALL_DIR.patch b/meta/recipes-extended/libsolv/libsolv/0001-CMakeLists.txt-fix-MAN_INSTALL_DIR.patch
new file mode 100644
index 0000000000..972ecc9c53
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv/0001-CMakeLists.txt-fix-MAN_INSTALL_DIR.patch
@@ -0,0 +1,37 @@
+From 280f0d37c642d68bad2a2e49ef437953474d99e6 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Wed, 6 Apr 2016 23:15:02 -0700
+Subject: [PATCH] CMakeLists.txt: fix MAN_INSTALL_DIR
+
+It checks ${CMAKE_INSTALL_PREFIX}/share/man when configure, but it may
+not exist when crosscompile, for example, when CMAKE_INSTALL_PREFIX="/",
+it is OK, but when CMAKE_INSTALL_PREFIX="/some/path/else", then it
+doesn't exist, and the man dir would be set to "/usr/man" which is
+incorrect.
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ CMakeLists.txt | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fd1426b..747db22 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -57,10 +57,7 @@ else (DEFINED INCLUDE)
+ ENDIF (DEFINED INCLUDE)
+ MESSAGE (STATUS "Header files will be installed in ${INCLUDE_INSTALL_DIR}")
+ SET (BIN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/bin")
+-SET (MAN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/man")
+-IF (IS_DIRECTORY "${CMAKE_INSTALL_PREFIX}/share/man" AND NOT IS_DIRECTORY "${CMAKE_INSTALL_PREFIX}/man")
+- SET (MAN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/share/man")
+-ENDIF (IS_DIRECTORY "${CMAKE_INSTALL_PREFIX}/share/man" AND NOT IS_DIRECTORY "${CMAKE_INSTALL_PREFIX}/man")
++SET (MAN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/share/man")
+ MESSAGE(STATUS "Man pages will be installed in ${MAN_INSTALL_DIR}")
+
+ ####################################################################
+--
+2.7.4
+
diff --git a/meta/recipes-extended/libsolv/libsolv_git.bb b/meta/recipes-extended/libsolv/libsolv_git.bb
index c0b012049f..fb81c8a5fa 100644
--- a/meta/recipes-extended/libsolv/libsolv_git.bb
+++ b/meta/recipes-extended/libsolv/libsolv_git.bb
@@ -9,7 +9,9 @@ DEPENDS = "expat zlib"
PV = "0.6.19"
-SRC_URI = "git://github.com/openSUSE/libsolv.git"
+SRC_URI = "git://github.com/openSUSE/libsolv.git \
+ file://0001-CMakeLists.txt-fix-MAN_INSTALL_DIR.patch \
+"
SRCREV = "4c5af401a89858d4cebbfe40c59a0031ff9db5b0"
UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"