aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 18:17:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-13 13:59:45 +0000
commitaa458b5fdb8d5d0ac93ced3b198bef2daa4e24b4 (patch)
tree312131e82ce2cdb0db0d2890b91ec1c317659bd6
parent5288e401c769a80f499d0775dd9bd1304e2298f4 (diff)
downloadopenembedded-core-contrib-aa458b5fdb8d5d0ac93ced3b198bef2daa4e24b4.tar.gz
python3-iniparse: use pypi.bbclass
* Simplify recipe by using pypi.bbclass Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-iniparse_0.4.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python3-iniparse_0.4.bb b/meta/recipes-devtools/python/python3-iniparse_0.4.bb
index f51ce647c9..4eba9ecd34 100644
--- a/meta/recipes-devtools/python/python3-iniparse_0.4.bb
+++ b/meta/recipes-devtools/python/python3-iniparse_0.4.bb
@@ -4,17 +4,14 @@ LICENSE = "MIT & PSF"
LIC_FILES_CHKSUM = "file://LICENSE-PSF;md5=1c78a5bb3584b353496d5f6f34edb4b2 \
file://LICENSE;md5=52f28065af11d69382693b45b5a8eb54"
-SRC_URI = "https://files.pythonhosted.org/packages/source/i/iniparse/iniparse-${PV}.tar.gz \
- file://0001-Add-python-3-compatibility.patch "
+SRC_URI = "file://0001-Add-python-3-compatibility.patch "
+
SRC_URI[md5sum] = "5e573e9e9733d97623881ce9bbe5eca6"
SRC_URI[sha256sum] = "abc1ee12d2cfb2506109072d6c21e40b6c75a3fe90a9c924327d80bc0d99c054"
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/iniparse/"
-inherit distutils3
+inherit pypi distutils3
RDEPENDS_${PN} += "python3-core python3-six"
DEPENDS += "python3-six"
BBCLASSEXTEND = "native nativesdk"
-
-S = "${WORKDIR}/iniparse-${PV}"