summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-07-31 12:53:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-31 23:03:01 +0100
commita4bb53437ee277f3587767574a29cf45939dcea7 (patch)
tree4c27bdd5ba55742745f39bf11ab54d47aed8acbf
parent1ea5b2f0745c359223b4df7559e915ee677ea876 (diff)
downloadopenembedded-core-contrib-a4bb53437ee277f3587767574a29cf45939dcea7.tar.gz
fortran-helloworld: neaten recipe
Use ${FC} instead of constructing the fortran name/arguments explictly, and clean up installation. (From OE-Core rev: a0d85e117fb636ffa12253b19f0ab2b5055e6380) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta-selftest/recipes-test/fortran/fortran-helloworld.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-selftest/recipes-test/fortran/fortran-helloworld.bb b/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
index 97313d7e24..3a46404477 100644
--- a/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
+++ b/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
@@ -11,15 +11,14 @@ SECURITY_CFLAGS = ""
SECURITY_LDFLAGS = ""
do_compile() {
- ${HOST_PREFIX}gfortran ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS} ${LDFLAGS} ${WORKDIR}/hello.f95 -o ${B}/fortran-hello
+ ${FC} ${LDFLAGS} ${WORKDIR}/hello.f95 -o ${B}/fortran-hello
}
do_install() {
- install -d ${D}${bindir}
- install ${B}/fortran-hello ${D}${bindir}
+ install -D ${B}/fortran-hello ${D}${bindir}/fortran-hello
}
python () {
if not d.getVar("FORTRAN"):
raise bb.parse.SkipRecipe("Fortran isn't enabled")
-} \ No newline at end of file
+}