aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Kroon <jacob.kroon@gmail.com>2018-12-25 10:20:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-11 10:38:21 +0000
commit490d6fbd14805b6c72b525fbe8c9c6e08d796597 (patch)
treeb21257a244b1b8152f35bd28c6381f36d185159e
parentc4a931df28f45f95f19a13062b8dc38db60da342 (diff)
downloadopenembedded-core-contrib-490d6fbd14805b6c72b525fbe8c9c6e08d796597.tar.gz
initramfs-boot: create /dev/console
The Yocto kernel expects a proper /dev/console to exist before running init, otherwise booting will fail with the message: Kernel panic - not syncing: /dev/console is missing or not a character device! Please ensure your rootfs is properly configured Add similar fix as was done for initramfs-framework and initramfs-live-boot in commits 0352841cd92f6316bcac092e2fff9d28c352b36b 1b64664f0c388f41084f5db6e46e3e68c53fb6d9 Signed-off-by: Jacob Kroon <jacob.kroon@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
index 7ae7969f5e..29ec5ec2ff 100644
--- a/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
+++ b/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
@@ -9,8 +9,13 @@ S = "${WORKDIR}"
do_install() {
install -m 0755 ${WORKDIR}/init-boot.sh ${D}/init
+
+ # Create device nodes expected by some kernels in initramfs
+ # before even executing /init.
+ install -d ${D}/dev
+ mknod -m 622 ${D}/dev/console c 5 1
}
inherit allarch
-FILES_${PN} += " /init "
+FILES_${PN} += "/init /dev/console"