aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Seebach <peter.seebach@windriver.com>2015-09-04 17:16:27 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-06 15:24:28 +0100
commit8402958cd2cb87b8283c8ee4e2d08e1a6717d67a (patch)
tree4422fd79eb9a0fc6222a7b9e78bb2da627ab19a6
parent237b6c51b42b0c64434dc45685e10f757ac939c2 (diff)
downloadopenembedded-core-contrib-8402958cd2cb87b8283c8ee4e2d08e1a6717d67a.tar.gz
pseudo_1.7.3.bb: New version of pseudo
Pseudo 1.7 adds an experimental feature (which I think needs more testing before it becomes the default) allowing the pseudo client to store modes and uid/gid values in extended attributes rather than using the sqlite database. On most Linux-like systems, this works only if the underlying file is a plain file or a directory. Also added is a profiling feature to allow some amount of reporting on the wall-clock time the client spends in wrappers, processing operations, or in IPC. This feature is not intendeded to be precisely accurate, but gives a good overview of where time is going. Based on the results from the profiling feature, the client now suppresses OP_OPEN and OP_EXEC messages if the server is not logging messages, and no longer uses constant dynamic allocation and free cycles for canonicalized paths. There's a few other likely-looking optimizations being considered, but this seemed like a good cutoff for now. 1.7.1 fixes two bugs, one affecting mostly XFS systems with 64-bit inode values, and one affecting code that called realpath(x, NULL), such as the RPM backend. 1.7.2 fixes an indirect side-effect of the chmod fixes to deal with umask 0700, which had no effect with opkg 0.2.4 but appears to cause failures with 0.3.0. 1.7.3 prevents mkdirat() (and mkfifoat()) from setting errno on success, because glibc's localedef inexplicably errors out if errno was set, even if the operation's actual return code (which it tests) indicated success. Signed-off-by: Peter Seebach <peter.seebach@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.7.3.bb19
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb4
2 files changed, 21 insertions, 2 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.7.3.bb b/meta/recipes-devtools/pseudo/pseudo_1.7.3.bb
new file mode 100644
index 0000000000..1e9ef3bb98
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo_1.7.3.bb
@@ -0,0 +1,19 @@
+require pseudo.inc
+
+SRC_URI = " \
+ http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \
+ file://fallback-passwd \
+ file://fallback-group \
+"
+
+SRC_URI[md5sum] = "2bd0a44eadd4713e90ad8c152eea77aa"
+SRC_URI[sha256sum] = "e9fc3922f8feb97839b50d14eb1987afdc8f22cdcac93119323cccd5f8444652"
+
+PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
+
+do_install_append_class-native () {
+ install -d ${D}${sysconfdir}
+ # The fallback files should never be modified
+ install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
+ install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
+}
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index aa315d3ed5..31e1223a48 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -1,7 +1,7 @@
require pseudo.inc
-SRCREV = "db758fb11167c79d9682a17d359568e2a3c4acd5"
-PV = "1.6.5+git${SRCPV}"
+SRCREV = "e795df44a90a426a76b790f1b2774f3046a8fc31"
+PV = "1.7.2+git${SRCPV}"
DEFAULT_PREFERENCE = "-1"