aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-10-23 04:22:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-10-24 12:20:41 +0100
commit02ad8e3c32656a74fa82284105706ae67e5108f3 (patch)
treec41b868555c91f91464e6a1d11feea5e6bb1cc7c
parent9c7ffd397c8232d53c87017e58e03e3056863edf (diff)
downloadopenembedded-core-contrib-02ad8e3c32656a74fa82284105706ae67e5108f3.tar.gz
e2fsprogs: backport a patch to fix filetype for hardlink
Backport a patch to fix hardlinks filetype: IMAGE_INSTALL_append = " e2fsprogs" $ ./tmp/sysroots/x86_64-linux/sbin/fsck.ext4 tmp/deploy/images/qemux86/core-image-minimal-qemux86.ext4 -f Pass 1: Checking inodes, blocks, and sizes Pass 2: Checking directory structure Setting filetype for entry 'fsck.ext2' in /sbin (80) to 1. Setting filetype for entry 'mkfs.ext4' in /sbin (80) to 1. Setting filetype for entry 'fsck.ext4' in /sbin (80) to 1. Setting filetype for entry 'mkfs.ext4dev' in /sbin (80) to 1. Setting filetype for entry 'fsck.ext3' in /sbin (80) to 1. Setting filetype for entry 'mkfs.ext2' in /sbin (80) to 1. Setting filetype for entry 'mkfs.ext3' in /sbin (80) to 1. Setting filetype for entry 'e2fsck' in /sbin (80) to 1. Pass 3: Checking directory connectivity Pass 4: Checking reference counts Pass 5: Checking group summary information test.img: ***** FILE SYSTEM WAS MODIFIED ***** test.img: 799/65536 files (0.1% non-contiguous), 14652/262144 blocks Now when run it again, we may get: [snip] Pass 3A: Optimizing directories [snip] test.img: ***** FILE SYSTEM WAS MODIFIED ***** test.img: 799/65536 files (0.1% non-contiguous), 14652/262144 blocks This is fine since it is optimizing, from "man e2fsck": e2fsck may sometimes optimize a few directories --- for example, if directory indexing is enabled and a directory is not indexed and would benefit from being indexed, or if the index structures are corrupted and need to be rebuilt. [YOCTO #8544] Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs/copy-in-create-hardlinks-with-the-correct-directory-.patch81
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb1
2 files changed, 82 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs/copy-in-create-hardlinks-with-the-correct-directory-.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs/copy-in-create-hardlinks-with-the-correct-directory-.patch
new file mode 100644
index 0000000000..f549693570
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs/copy-in-create-hardlinks-with-the-correct-directory-.patch
@@ -0,0 +1,81 @@
+From 2dcf8e92bc39e05b3c799f53fe911c024aee4375 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Fri, 23 Oct 2015 03:21:05 -0700
+Subject: [PATCH] copy-in: create hardlinks with the correct directory
+ filetype
+
+When we're creating hard links via ext2fs_link, the (misnamed?) flags
+argument specifies the filetype for the directory entry. This is
+*derived* from i_mode, so provide a translator. Otherwise, fsck will
+complain about unset file types.
+
+Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
+Signed-off-by: Theodore Ts'o <tytso@mit.edu>
+
+Upstream-Status: Backport
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ misc/create_inode.c | 33 +++++++++++++++++++++++++++++++--
+ 1 file changed, 31 insertions(+), 2 deletions(-)
+
+diff --git a/misc/create_inode.c b/misc/create_inode.c
+index fcec5aa..b8565da 100644
+--- a/misc/create_inode.c
++++ b/misc/create_inode.c
+@@ -22,6 +22,33 @@
+ /* For saving the hard links */
+ int hdlink_cnt = HDLINK_CNT;
+
++static int ext2_file_type(unsigned int mode)
++{
++ if (LINUX_S_ISREG(mode))
++ return EXT2_FT_REG_FILE;
++
++ if (LINUX_S_ISDIR(mode))
++ return EXT2_FT_DIR;
++
++ if (LINUX_S_ISCHR(mode))
++ return EXT2_FT_CHRDEV;
++
++ if (LINUX_S_ISBLK(mode))
++ return EXT2_FT_BLKDEV;
++
++ if (LINUX_S_ISLNK(mode))
++ return EXT2_FT_SYMLINK;
++
++ if (LINUX_S_ISFIFO(mode))
++ return EXT2_FT_FIFO;
++
++ if (LINUX_S_ISSOCK(mode))
++ return EXT2_FT_SOCK;
++
++ return 0;
++}
++
++
+ /* Link an inode number to a directory */
+ static errcode_t add_link(ext2_ino_t parent_ino, ext2_ino_t ino, const char *name)
+ {
+@@ -34,14 +61,16 @@ static errcode_t add_link(ext2_ino_t parent_ino, ext2_ino_t ino, const char *nam
+ return retval;
+ }
+
+- retval = ext2fs_link(current_fs, parent_ino, name, ino, inode.i_flags);
++ retval = ext2fs_link(current_fs, parent_ino, name, ino,
++ ext2_file_type(inode.i_mode));
+ if (retval == EXT2_ET_DIR_NO_SPACE) {
+ retval = ext2fs_expand_dir(current_fs, parent_ino);
+ if (retval) {
+ com_err(__func__, retval, "while expanding directory");
+ return retval;
+ }
+- retval = ext2fs_link(current_fs, parent_ino, name, ino, inode.i_flags);
++ retval = ext2fs_link(current_fs, parent_ino, name, ino,
++ ext2_file_type(inode.i_mode));
+ }
+ if (retval) {
+ com_err(__func__, retval, "while linking %s", name);
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
index 97e29c8916..ce7d2e8628 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
@@ -23,6 +23,7 @@ SRC_URI += "file://acinclude.m4 \
file://cache_inode.patch \
file://CVE-2015-0247.patch \
file://0001-libext2fs-fix-potential-buffer-overflow-in-closefs.patch \
+ file://copy-in-create-hardlinks-with-the-correct-directory-.patch \
"
SRC_URI[md5sum] = "3f8e41e63b432ba114b33f58674563f7"