aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-09-21 09:14:58 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-21 14:20:16 +0100
commit1c6c1af385a481b0a57ab06cd40af56be3425cc8 (patch)
treec6de51bdef27fc0437173b3d579b80d02acf8d5e
parent440ad49e53359ea800c179df105ab885873d7691 (diff)
downloadopenembedded-core-contrib-1c6c1af385a481b0a57ab06cd40af56be3425cc8.tar.gz
linux-yocto/4.1: hid-core: Avoid uninitialized buffer access
Updating the 4.1 SRCREVs to integrate the following commit: hid-core: Avoid uninitialized buffer access hid_connect adds various strings to the buffer but they're all conditional. You can find circumstances where nothing would be written to it but the kernel will still print the supposedly empty buffer with printk. This leads to corruption on the console/in the logs. Ensure buf is initialized to an empty string. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> [dvhart: Initialize string to "" rather than assign buf[0] = NULL;] Cc: Jiri Kosina <jikos@kernel.org> Cc: linux-input@vger.kernel.org Cc: stable@vger.kernel.org Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 7265cde3fa..4e2db91dfc 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
+SRCREV_machine ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
SRCREV_meta ?= "ef417dc3dbac098e2273b9157bf7ea8b1ade0ec5"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index b0619702f7..396bc21e5e 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.6"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
+SRCREV_machine ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
SRCREV_meta ?= "ef417dc3dbac098e2273b9157bf7ea8b1ade0ec5"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index d974842810..d72c5a7e1b 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
-SRCREV_machine_qemuarm64 ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
-SRCREV_machine_qemumips ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
-SRCREV_machine_qemuppc ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
-SRCREV_machine_qemux86 ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
-SRCREV_machine_qemux86-64 ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
-SRCREV_machine_qemumips64 ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
-SRCREV_machine ?= "f830ab33799d6e0b5433c18c5c6c3c68dce17815"
+SRCREV_machine_qemuarm ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
+SRCREV_machine_qemuarm64 ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
+SRCREV_machine_qemumips ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
+SRCREV_machine_qemuppc ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
+SRCREV_machine_qemux86 ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
+SRCREV_machine_qemux86-64 ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
+SRCREV_machine_qemumips64 ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
+SRCREV_machine ?= "ff7ef77f1350cce9b50cc5abbf48926c83fd32a8"
SRCREV_meta ?= "ef417dc3dbac098e2273b9157bf7ea8b1ade0ec5"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \