summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-09-25 14:36:09 +0800
committerRobert Yang <liezhi.yang@windriver.com>2019-09-26 10:47:00 +0800
commitacf2ac895d9134ca4b03b43bf139e2685d4281a7 (patch)
tree4a60dbcb37195c59aee828237446ab55e1e8f913
parent95ad5626296380358c8a502a3e04879dab653d78 (diff)
downloadopenembedded-core-contrib-acf2ac895d9134ca4b03b43bf139e2685d4281a7.tar.gz
expect: Fix configure error for nativesdk
Fixed: $ bitbake nativesdk-expect checking for Tcl public headers... configure: error: tcl.h not found. Please specify its location with --with-tclinclude Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.4.bb b/meta/recipes-devtools/expect/expect_5.45.4.bb
index 96eacd9293..5f59083ad2 100644
--- a/meta/recipes-devtools/expect/expect_5.45.4.bb
+++ b/meta/recipes-devtools/expect/expect_5.45.4.bb
@@ -44,9 +44,9 @@ do_install_append() {
}
# Apparently the public Tcl headers are only in /usr/include/tcl8.6
-# when building for the target.
-TCL_INCLUDE_PATH = ""
-TCL_INCLUDE_PATH_class-target = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
+# when building for the target and nativesdk.
+TCL_INCLUDE_PATH = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
+TCL_INCLUDE_PATH_class-native = ""
EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \
--enable-shared \