aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-10-18 06:28:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-20 22:39:25 +0100
commitd819e7fa76e2b732aa7c33ab0e9a834781090824 (patch)
treee4cac285db7719922f85f863bf0fab7fec571132
parent112775995158cf6c504fd6beef345ee446f4f11d (diff)
downloadopenembedded-core-contrib-d819e7fa76e2b732aa7c33ab0e9a834781090824.tar.gz
perf: fix do_compile failure with /tmp mounted with noexec
On a builder which has /tmp mounted nexec, the ARM64 generation of the sycall table will fail: [snip] |perf-1.0/tools/perf/arch/arm64/entry/syscalls//mksyscalltbl: /tmp/create-table-6VGPSt: Permission denied [snip] To avoid the permission denied error, we must instruct the perf build to place temporary files in an appropriate directory (versus always using /tmp). To do this, we need both a kernel source change to perf, and a recipe change to pass the temp directory in by a TMPDIR variable. The linux-yocto has a reference kernel change: [perf arm64: Fix generate system call table failed with /tmp mounted with noexec], that has also been submitted upstream mailing list linux-perf-users@vger.kernel.org Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Reviewed-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 586422f769..af099043e1 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -75,6 +75,7 @@ EXTRA_OEMAKE = '\
perfexecdir=${libexecdir} \
NO_GTK2=1 \
${PACKAGECONFIG_CONFARGS} \
+ TMPDIR="${B}" \
'
EXTRA_OEMAKE += "\