summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2019-09-11 11:32:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-16 23:02:44 +0100
commit7ae68c580cc9ff1e2ba3c65b84cf3a02ebaaaac1 (patch)
tree76ac042b944f0d3b5c35b16cd0ffcdbf51204688
parent100bf17470211abd499a3b8700b2d0c221b2d3ea (diff)
downloadopenembedded-core-contrib-7ae68c580cc9ff1e2ba3c65b84cf3a02ebaaaac1.tar.gz
gnupg: Extend -native wrapper to fix gpgme-native's gpgconf problems
The gpg commit signing in ostree-native doesn't work properly when running from sstate. The ostree-native is linked with gpgme-native's libraries, which have calls into gpg. Ultimately it turned out the problem was that gpgme calls gpgconf and some of the other gnupg-native binaries directly. Not all the binaries have a wrapper which sets the environment variable GNUPG_BIN. Without this wrapper these binaries it gets the path assignment from the original compilation which causes a fault when running from sstate in a new tmp directory because these paths will not exist. (From OE-Core rev: f93bf3bd051923618ce3949d5686fdb8cf998645) Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.17.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.17.bb b/meta/recipes-support/gnupg/gnupg_2.2.17.bb
index e5456dd9b9..689cf8a75e 100644
--- a/meta/recipes-support/gnupg/gnupg_2.2.17.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.2.17.bb
@@ -46,6 +46,9 @@ do_install_append() {
do_install_append_class-native() {
create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
+ create_wrapper ${D}${bindir}/gpgconf GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
+ create_wrapper ${D}${bindir}/gpg-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
+ create_wrapper ${D}${bindir}/gpg-connect-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
}
PACKAGECONFIG ??= "gnutls"