summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-27 14:15:24 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-27 22:40:36 +0000
commita3b59a67bea16899b57a0d187120c988495da4d5 (patch)
treeefe921934e2f01d249eaad07febbe2322f60031c
parentae9cad4e0554c8fe91d64030ad5c7e6d67b713d6 (diff)
downloadopenembedded-core-contrib-a3b59a67bea16899b57a0d187120c988495da4d5.tar.gz
bootchart2: Fix manpage reproducibility issue
The compressed docs contained a timestamp of the original file which meant the SDE clamping during package creation didn't work. The benefits of compression are minor, decompress the files to avoid the reproducibility issues. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/lib/oeqa/selftest/cases/reproducible.py1
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb3
2 files changed, 3 insertions, 1 deletions
diff --git a/meta/lib/oeqa/selftest/cases/reproducible.py b/meta/lib/oeqa/selftest/cases/reproducible.py
index 05fc4b7fa0..ff3e3be63f 100644
--- a/meta/lib/oeqa/selftest/cases/reproducible.py
+++ b/meta/lib/oeqa/selftest/cases/reproducible.py
@@ -28,7 +28,6 @@ import datetime
# ruby-ri-docs, meson:
#https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20210215-0_td9la2/packages/diff-html/
exclude_packages = [
- 'bootchart2-doc',
'efivar',
'glide',
'go-dep',
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
index 6571c19938..f6a77b4606 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
@@ -139,6 +139,9 @@ do_install () {
# Use python 3 instead of python 2
sed -i -e '1s,#!.*python.*,#!${USRBINPATH}/env python3,' ${D}${bindir}/pybootchartgui
+
+ # The timestamps embedded in compressed man pages is not reproducible
+ gzip -d ${D}${mandir}/man1/*.gz
}
PACKAGES =+ "pybootchartgui"